Ticket #28940

Amateras UML to work with java 7

Open Date: 2012-07-08 06:04 Last Update: 2012-07-17 00:04

Reporter:
Owner:
Status:
Closed
Component:
MileStone:
(None)
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
None

Details

Hi. Amateras UML breaks when using java 7 + eclipse. I can see the information of the diagrams elements if I open it as text. But when I open it as diagram, it renders a white page.
I really liked the tool, but this is a deal breaker!
Thanks a lot in advance!
Best regards,
Ricardo

Ticket History (3/15 Histories)

2012-07-08 06:04 Updated by: rvmfonseca
  • New Ticket "Amateras UML to work with java 7" created
2012-07-09 02:00 Updated by: takezoe
  • Owner Update from (None) to takezoe
Comment

Thanks for your feedback.

I want some more information for testing in my environment. What version of Eclipse are you using?

2012-07-09 02:55 Updated by: rvmfonseca
Comment

Hi. Here follows the requeste info:

Eclipse Version: Indigo Service Release 2 Build id: 20120216-1857

JDK 7

Plugin details: Project Amateras UML Plugin 1.3.3 Project Amateras UML Java Generator Plug-in 1.3.3

2012-07-09 12:11 Updated by: takezoe
Comment

Sorry, I have one more question. Are your JDK and Eclipse 64 bit version?

2012-07-09 12:50 Updated by: rvmfonseca
Comment

Reply To takezoe

Sorry, I have one more question. Are your JDK and Eclipse 64 bit version?

Sure, no problem. Ask as many questions as you need.
- Windows Vista Home Premium 64 bits
- java.version=1.7.0_04; java.vm.name=Java HotSpot(TM) 64-Bit Server VM
- Eclipse

--launcher.library D:\programacao\java\ide\eclipse3.7\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.100.v20110502\eclipse_1406.dll

So I believe the answer is yes. Both are 64 bit. I could find some people in the forums with the same problem. They said that when they changed to java 6 the problem was solved. But this is not an option for me. Reference: http://sourceforge.jp/forum/forum.php?forum_id=3586&thread_id=30216
Thanks
2012-07-09 13:39 Updated by: takezoe
Comment

Thanks, I'll investigate.

2012-07-14 04:31 Updated by: takezoe
Comment

I put AmaterasUML 1.3.3 which is compiled by JDK 1.7 into the following URL: http://amateras.sourceforge.jp/files/amaterasuml/

It worked with 64bit version of JDK 1.7 and Indigo in my environment. Coukd you try it?

2012-07-14 05:54 Updated by: rvmfonseca
Comment

Reply To takezoe

I put AmaterasUML 1.3.3 which is compiled by JDK 1.7 into the following URL: http://amateras.sourceforge.jp/files/amaterasuml/ It worked with 64bit version of JDK 1.7 and Indigo in my environment. Coukd you try it?

Hi.

It didn't work :(

I tried 2 times. First I closed eclipse, deleted the original jars, put the new ones there and restarted eclipse.

Then I closed eclipse, removed the jars, opened eclipse (it couldn't read the .cld), closed it, put the new jars again, but the problem persisted.

You said it worked at your place, right? Maybe it's some external dependency... I have a subversion plugin and a javafx plugin installed. This weekend I'll try with a fresh Eclipse installation and will let you know.

Thanks!

2012-07-15 04:06 Updated by: rvmfonseca
Comment

Reply To rvmfonseca

Reply To takezoe

I put AmaterasUML 1.3.3 which is compiled by JDK 1.7 into the following URL: http://amateras.sourceforge.jp/files/amaterasuml/ It worked with 64bit version of JDK 1.7 and Indigo in my environment. Coukd you try it?

Hi. It didn't work :( I tried 2 times. First I closed eclipse, deleted the original jars, put the new ones there and restarted eclipse. Then I closed eclipse, removed the jars, opened eclipse (it couldn't read the .cld), closed it, put the new jars again, but the problem persisted. You said it worked at your place, right? Maybe it's some external dependency... I have a subversion plugin and a javafx plugin installed. This weekend I'll try with a fresh Eclipse installation and will let you know. Thanks!

Hi again. I tried with a brand new installation of Eclipse Indigo but the outcome was the same. I can create and edit the diagram but after I close it, it renders a white page when I try to reopen it, even though the diagram elements are there (I can see it when I open the diagram as text).

Could you really make it work with this version you let available for download?

Best regards, Ricardo

2012-07-15 15:10 Updated by: takezoe
Comment

Hi Recardo,

Sorry, I couldn't fix a problem correctly in the previous uploaded plug-in.
I updated a plug-in again, please try it:
http://amateras.sourceforge.jp/files/amaterasuml/AmaterasUML1.3.3.20120715.zip

2012-07-15 21:20 Updated by: rvmfonseca
Comment

Reply To takezoe

Hi Recardo, Sorry, I couldn't fix a problem correctly in the previous uploaded plug-in.
I updated a plug-in again, please try it:
http://amateras.sourceforge.jp/files/amaterasuml/AmaterasUML1.3.3.20120715.zip

Hi! It worked! Thanks a lot!

Is that link something official which I can tell the other guys they can use?

Best regards,

Ricardo

2012-07-16 10:57 Updated by: takezoe
Comment

rvmfonseca への返信

Is that link something official which I can tell the other guys they can use?

This is a development version. It needs more test and some additional changes might be added in the next release.

So we can't recommend to use the development version but of course, your feedback for the development version is welcome.

Anyway, we'll release AmaterasUML 1.3.4 as soon as possible.

2012-07-16 11:01 Updated by: rvmfonseca
  • Resolution Update from None to Fixed
  • Status Update from Open to Closed
  • Ticket Close date is changed to 2012-07-16 11:01
Comment

Reply To takezoe

rvmfonseca への返信

Is that link something official which I can tell the other guys they can use?

This is a development version. It needs more test and some additional changes might be added in the next release. So we can't recommend to use the development version but of course, your feedback for the development version is welcome. Anyway, we'll release AmaterasUML 1.3.4 as soon as possible.

Ok, thank you again. I'm closing this ticket. I'll let you know if I can think about any useful feedback

2012-07-16 23:39 Updated by: takezoe
Comment

Hi Recardo,

I found a actual reason of this problem. It's caused by old version of XStream. I replaced it to the latest version of XStream. Then problem was resolved.

The development version that is uploaded by me yesterday breaks compartibility of file format. So I will roll back this fix and release 1.3.4 with the latest version of XStream.

Again, don't use the development version in production. Please wait for the next release. I will release as soon as possible.

2012-07-17 00:04 Updated by: takezoe
Comment

Hi Recardo,

We released AmaetrasUML 1.3.4 just now. Please use it instead of the development version: http://sourceforge.jp/projects/amateras/downloads/56447/AmaterasUML_1.3.4.zip/

Attachment File List

No attachments

Edit

Please login to add comment to this ticket » Login