Ticket #31988

issue of substr

Open Date: 2013-09-04 17:07 Last Update: 2013-09-30 13:42

Reporter:
Owner:
Type:
Status:
Closed
Component:
(None)
MileStone:
(None)
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
None
File:
None

Details

When cutting one last character of the string by using the substr function in awk script raises an exception. awkスクリプトでsubstr関数を利用して文字列の最後の1文字を切り出すと、例外が発生する。

e.g.) val="12345"; print substr(val, 5 ,1);

Ticket History (3/3 Histories)

2013-09-04 17:07 Updated by: toudate
  • New Ticket "issue of substr" created
2013-09-08 14:57 Updated by: y-moriguchi
  • Owner Update from (None) to y-moriguchi
Comment

This bug is caused by boundary check of the string. The source is fixed and committed to the Subversion (revision 56).
このバグは文字列の長さチェックにおいて有効な文字長を1つ短くしていたため発生しました。 バグを修正してSubversionにコミットしました(リビジョン56)。

2013-09-30 13:42 Updated by: toudate
  • Status Update from Open to Closed
  • Ticket Close date is changed to 2013-09-30 13:42
Comment

I confirmed fixed. thank you.
修正ありがとうございます、確認しました。

Attachment File List

No attachments

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login