• R/O
  • HTTP
  • SSH
  • HTTPS

CharacterManaJ: Commit

キャラクターなんとかJの本体


Commit MetaInfo

Revision1b05b1168c69d50a120664f4d96e65b7aeecbedb (tree)
Time2019-01-28 03:18:21
Authorseraphy <seraphy@user...>
Commiterseraphy

Log Message

Aboutの文言の更新

Change Summary

Incremental Difference

--- a/src/main/resources/appinfo/about.html
+++ b/src/main/resources/appinfo/about.html
@@ -17,51 +17,31 @@ h2 {
1717 <h1><font color="blue"><b>ChracterManaJ</b> Version @@SPECIFICATION-VERSIONINFO@@</font></h1>
1818 <div style="text-align: right;">Implementation-Version: @@IMPLEMENTS-VERSIONINFO@@</div>
1919
20-<h2>[Software Requirements]</h2>
21-<p>Use in the following environment is assumed.</p>
22-<ul>
23- <li>Mac OS X
24- <ul>
25- <li>10.8 Mountain Lion (Apple Java6 or Oracle Java7 later)</li>
26- <li>10.9 Mavericks (Apple Java6 or Oracle Java7 later)</li>
27- <li>10.10 Yosemite (Apple Java6 or Oracle Java7 later)</li>
28- <li>10.11 El Capitan (Java8 or later)</li>
29- <li>10.12 Sierra (Java8 or later)</li>
30- <li>10.13 High Sierra (Java8 or later)</li>
31- <li>10.14 Mojave (Java8 or later)</li>
32- </ul>
33- </li>
34- <li>Microsoft Windows
35- <ul>
36- <li>Windows 7 (32/64Bit) Java6 or later</li>
37- <li>Windows 10 (32/64Bit) Java6 or later</li>
38- </ul>
39- </li>
40- <li>Linux
41- <ul>
42- <li>Supports Java 6 desktop environment. (e.g. Ubuntu 18.10 with openjdk-8-jre)</li>
43- </ul>
44- </li>
45-</ul>
46-<p>This application can run in an environment compatible with Java 6.</p>
47-
48-<p>Java8 is recommended.</p>
49-<p>"<font color="red">lib/charsets.jar</font>" is indispensable in order to treat a Japanese file name.</p>
50-<p>When "lib/charsets.jar" does not exist, it is necessary to re-install JRE. <br>
51-(For example, when "East Asian Languages" is installed afterwards.) </p>
52-<hr>
53-<p><font color="gray">Could someone please translate this japanese text.</font></p>
54-
5520 <h2>[About this software]</h2>
56-<p>このアプリケーションは複数の画像を選択し重ね合わせることで一つの画像を作り出す、モンタージュを行うアプリケーションです。</p>
57-<p>用途としてパーツを組み合わせてキャラクターをデザインするという、一種の着せ替えを楽しむことを想定していますが、それに限りません。</p>
58-<p>モンタージュするための素材の画像データがないと、このアプリケーションは何もできません。ご自身で作成するか、既にある画像データを用意するなどしてください。</p>
59-<p>カテゴリ、レイヤー、カラーグループを増減させたりなど、画像の組み合わせ方については新しいプロファイルを作成することで自分好みの設定にすることができます。</p>
21+<p>CharacterManaJ is an application to create a single image by superimposing multiple selected images.</p>
22+<p>It is able to design the avatar by different dresses and different parts by layering them, but not limited to it.</p>
23+<p>In order to run charactermanaj you need to have some images first.</p>
24+<p><b><font color="red">Important!</font></b> This program does not include image data.</p>
25+<p>Please prepare the data yourself. Refer to the Wiki document for the procedure.</p>
26+
6027 <p>このアプリケーションは、<a href="http://khmix.sakura.ne.jp/">K.Hみっくす ふぁーすとえでぃしょん さんの<br>
6128 「キャラクターなんとか機」</a>を目標にJAVAによりフルスクラッチから書き起こしたものです。</p>
6229 <p>初期状態で、「キャラクターなんとか機」と同じカテゴリ、レイヤー順序、ディレクトリ、カラーグループの設定がされたプロファイルが作成されますので、
6330 「キャラクターなんとか機」のパーツデータをインポートして使うことができます。</p>
6431
32+<h2>[Software Requirements]</h2>
33+<p>Use in the following environment is assumed.</p>
34+<ul>
35+ <li>Microsoft Windows 7 or 10 (32bit, 64bit)</li>
36+ <li>Mac OSX 10.8 Mountain Lion or later (To use the bundled JRE, OSX 10.10 Yosemite or later is required.)</li>
37+ <li>Ubuntu 14,16, etc. (To use the bundled JRE, Ubuntu 16 or later is required.)</li>
38+</ul>
39+<p>This application can run in an environment compatible with Java 6.</p>
40+<p>It is recommended to run it in Java 8.</p>
41+<p>Basically, it should work if Java 6 desktop is working environment.</p>
42+<p>If Java is not installed on your system or if you do not want to use Java on your system, please use the JRE bundled version.
43+(The included JRE is used only in this application. This will not install Java on your system. Registry, system folders etc are not rewritten at all.)</p>
44+
6545 <h2>[ライセンス/使用許諾条件]</h2>
6646 <p>「キャラクターなんとかJ」はオープンソースソフトウェアです。ソースコードは「The Apache License Version 2.0」です。</p>
6747 <p><font color="red">本ソフトウェアは完全に無保証です。</font>本ソフトウェアは「現状のまま」、かつ明示か暗黙であるかを問わず、一切の保証を付けずに提供されます。</p>
--- a/src/main/resources/appinfo/about_ja.html
+++ b/src/main/resources/appinfo/about_ja.html
@@ -46,38 +46,14 @@ h2 {
4646 そのかわり、各レイヤーごとに色の微調整ができるようにしているため、近い色を再現するはできると思います。
4747 その他、いろいろ不備があると思いますがご容赦ください。</p>
4848
49-<h2>[パーツデータの作者様へ]</h2>
50-<p>パーツデータをお持ちか、作成された方で、オープンソース系(たとえば<a href="http://creativecommons.jp/licenses/">クリエイティブコモンズ</a>など)
51-のライセンスで配布を許可くださる方は、ぜひ、ご連絡ください。</p>
52-<p>プロジェクトの配布ファイルに加えさせていただこうと思います。</p>
53-
5449 <h2>[動作環境]</h2>
5550 <p>以下の環境での利用を想定しています。</p>
5651 <ul>
57- <li>Mac OS X
58- <ul>
59- <li>10.8 Mountain Lion (Apple Java6 or Oracle Java7 later)</li>
60- <li>10.9 Mavericks (Apple Java6 or Oracle Java7 later)</li>
61- <li>10.10 Yosemite (Apple Java6 or Oracle Java7 later)</li>
62- <li>10.11 El Capitan (Java8 or later)</li>
63- <li>10.12 Sierra (Java8 or later)</li>
64- <li>10.13 High Sierra (Java8 or later)</li>
65- <li>10.14 Mojave (Java8 or later)</li>
66- </ul>
67- </li>
68- <li>Microsoft Windows
69- <ul>
70- <li>Windows 7 (32/64Bit) Java6 or later</li>
71- <li>Windows 10 (32/64Bit) Java6 or later</li>
72- </ul>
73- </li>
74- <li>Linux
75- <ul>
76- <li>Java6以降のデスクトップ環境をサポートするもの (例えば、Ubuntu 18.10 に openjdk-8-jre を入れたもの)</li>
77- </ul>
78- </li>
52+ <li>Microsoft Windows 7 or 10 (32bit, 64bit)</li>
53+ <li>Mac OSX 10.8 Mountain Lion 以降 (JRE同梱版を使う場合は OSX 10.10 Yosemite以降が必要です)</li>
54+ <li>Ubuntu 14,16, etc. (JRE同梱版を使う場合は Ubuntu 16 以降が必要です。)</li>
7955 </ul>
80-<p>Java6互換でコンパイルしているため、Java6以降のJavaがあれば動作します。Java11も可能です。</p>
56+<p>Java6互換でコンパイルしているため、基本的にはJava6以降のJavaがあれば動作します。Java11も利用可能です。</p>
8157
8258 <h2>[利用コンポーネントについて]</h2>
8359 <p>J2SE5の標準APIの他、Apache Antの一部(The Apache License Version 2.0)をライブラリとして使用しています。</p>
--- a/src/main/resources/appinfo/about_zh.html
+++ b/src/main/resources/appinfo/about_zh.html
@@ -54,33 +54,12 @@ h2 {
5454 <h2>[软件需求]</h2>
5555 <p>以下操作环境可以正常运行</p>
5656 <ul>
57- <li>Mac OS X
58- <ul>
59- <li>10.8 Mountain Lion (Apple Java6 or Oracle Java7 later)</li>
60- <li>10.9 Mavericks (Apple Java6 or Oracle Java7 later)</li>
61- <li>10.10 Yosemite (Apple Java6 or Oracle Java7 later)</li>
62- <li>10.11 El Capitan (Java8 or later)</li>
63- <li>10.12 Sierra (Java8 or later)</li>
64- <li>10.13 High Sierra (Java8 or later)</li>
65- <li>10.14 Mojave (Java8 or later)</li>
66- </ul>
67- </li>
68- <li>Microsoft Windows
69- <ul>
70- <li>Windows 7 (32/64Bit) Java6 or later</li>
71- <li>Windows 10 (32/64Bit) Java6 or later</li>
72- </ul>
73- </li>
74- <li>Linux
75- <ul>
76- <li>Supports Java 6 desktop environment. (e.g. Ubuntu 18.10 with openjdk-8-jre)</li>
77- </ul>
78- </li>
57+ <li>Microsoft Windows 7 or 10 (32bit, 64bit)</li>
58+ <li>Mac OSX 10.8 Mountain Lion or later (To use the bundled JRE, OSX 10.10 Yosemite or later is required.)</li>
59+ <li>Ubuntu 14,16, etc. (To use the bundled JRE, Ubuntu 16 or later is required.)</li>
7960 </ul>
8061 <p>推荐Java8以上</p>
81-<p>"<font color="red">lib/charsets.jar</font>"是必备运行库,用以处理日文字符</p>
82-<p>如果"lib/charsets.jar"不存在,你需要重新安装JRE(天朝人民可以无视这条)<br>
83-(比如安装了东亚语言包以前安装的JRE)</p>
62+
8463 <hr>
8564 <p><font color="gray">求好心人帮忙翻译下面的日文</font></p>
8665
Show on old repository browser