• R/O
  • SSH
  • HTTPS

chibios: Commit


Commit MetaInfo

Revision15624 (tree)
Time2022-05-13 20:39:06
Authorgdisirio

Log Message

Fixed a wrong preprocessor check.

Change Summary

Incremental Difference

--- branches/stable_20.3.x/os/hal/ports/STM32/LLD/TIMv1/hal_pwm_lld.h (revision 15623)
+++ branches/stable_20.3.x/os/hal/ports/STM32/LLD/TIMv1/hal_pwm_lld.h (revision 15624)
@@ -532,9 +532,9 @@
532532 !STM32_PWM_USE_TIM3 && !STM32_PWM_USE_TIM4 && \
533533 !STM32_PWM_USE_TIM5 && !STM32_PWM_USE_TIM8 && \
534534 !STM32_PWM_USE_TIM9 && !STM32_PWM_USE_TIM10 && \
535- !STM32_PWM_USE_TIM11 && !STM32_PWM_USE_TIM11 && \
536- !STM32_PWM_USE_TIM13 && !STM32_PWM_USE_TIM13 && \
537- !STM32_PWM_USE_TIM15 && !STM32_PWM_USE_TIM15 && \
535+ !STM32_PWM_USE_TIM11 && !STM32_PWM_USE_TIM12 && \
536+ !STM32_PWM_USE_TIM13 && !STM32_PWM_USE_TIM14 && \
537+ !STM32_PWM_USE_TIM15 && !STM32_PWM_USE_TIM16 && \
538538 !STM32_PWM_USE_TIM17 && !STM32_PWM_USE_TIM20 && \
539539 !STM32_PWM_USE_TIM21 && !STM32_PWM_USE_TIM22
540540 #error "PWM driver activated but no TIM peripheral assigned"
--- branches/stable_21.11.x/os/hal/ports/STM32/LLD/TIMv1/hal_pwm_lld.h (revision 15623)
+++ branches/stable_21.11.x/os/hal/ports/STM32/LLD/TIMv1/hal_pwm_lld.h (revision 15624)
@@ -520,9 +520,9 @@
520520 !STM32_PWM_USE_TIM3 && !STM32_PWM_USE_TIM4 && \
521521 !STM32_PWM_USE_TIM5 && !STM32_PWM_USE_TIM8 && \
522522 !STM32_PWM_USE_TIM9 && !STM32_PWM_USE_TIM10 && \
523- !STM32_PWM_USE_TIM11 && !STM32_PWM_USE_TIM11 && \
524- !STM32_PWM_USE_TIM13 && !STM32_PWM_USE_TIM13 && \
525- !STM32_PWM_USE_TIM15 && !STM32_PWM_USE_TIM15 && \
523+ !STM32_PWM_USE_TIM11 && !STM32_PWM_USE_TIM12 && \
524+ !STM32_PWM_USE_TIM13 && !STM32_PWM_USE_TIM14 && \
525+ !STM32_PWM_USE_TIM15 && !STM32_PWM_USE_TIM16 && \
526526 !STM32_PWM_USE_TIM17 && !STM32_PWM_USE_TIM20 && \
527527 !STM32_PWM_USE_TIM21 && !STM32_PWM_USE_TIM22
528528 #error "PWM driver activated but no TIM peripheral assigned"
--- trunk/os/hal/ports/STM32/LLD/TIMv1/hal_pwm_lld.h (revision 15623)
+++ trunk/os/hal/ports/STM32/LLD/TIMv1/hal_pwm_lld.h (revision 15624)
@@ -520,9 +520,9 @@
520520 !STM32_PWM_USE_TIM3 && !STM32_PWM_USE_TIM4 && \
521521 !STM32_PWM_USE_TIM5 && !STM32_PWM_USE_TIM8 && \
522522 !STM32_PWM_USE_TIM9 && !STM32_PWM_USE_TIM10 && \
523- !STM32_PWM_USE_TIM11 && !STM32_PWM_USE_TIM11 && \
524- !STM32_PWM_USE_TIM13 && !STM32_PWM_USE_TIM13 && \
525- !STM32_PWM_USE_TIM15 && !STM32_PWM_USE_TIM15 && \
523+ !STM32_PWM_USE_TIM11 && !STM32_PWM_USE_TIM12 && \
524+ !STM32_PWM_USE_TIM13 && !STM32_PWM_USE_TIM14 && \
525+ !STM32_PWM_USE_TIM15 && !STM32_PWM_USE_TIM16 && \
526526 !STM32_PWM_USE_TIM17 && !STM32_PWM_USE_TIM20 && \
527527 !STM32_PWM_USE_TIM21 && !STM32_PWM_USE_TIM22
528528 #error "PWM driver activated but no TIM peripheral assigned"
Show on old repository browser