Ticket #26285

終了時にcatalina.outにExceptionが発生する

Open Date: 2011-09-11 18:12 Last Update: 2011-09-29 21:26

Reporter:
Owner:
Type:
Status:
Closed
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
None

Details

2011/09/11 18:01:01 org.apache.catalina.startup.Catalina stop
致命的: Catalina.stop
org.apache.catalina.LifecycleException: Failed to stop component [StandardServer[8005]]
    at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:234)
    at org.apache.catalina.startup.Catalina.stop(Catalina.java:694)
    at org.apache.catalina.startup.Catalina.start(Catalina.java:655)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:322)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:450)
Caused by: org.apache.catalina.LifecycleException: Failed to stop component [StandardService[Catalina]]
    at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:234)
    at org.apache.catalina.core.StandardServer.stopInternal(StandardServer.java:748)
    at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:230)
    ... 8 more
Caused by: org.apache.catalina.LifecycleException: Failed to stop component [StandardEngine[Catalina]]
    at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:234)
    at org.apache.catalina.core.StandardService.stopInternal(StandardService.java:502)
    at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:230)
    ... 10 more
Caused by: org.apache.catalina.LifecycleException: Failed to stop component [StandardEngine[Catalina].StandardHost[localhost]]
    at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:234)
    at org.apache.catalina.core.ContainerBase.stopInternal(ContainerBase.java:1073)
    at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:230)
    ... 12 more
Caused by: org.apache.catalina.LifecycleException: Failed to stop component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/fess]]
    at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:234)
    at org.apache.catalina.core.ContainerBase.stopInternal(ContainerBase.java:1073)
    at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:230)
    ... 14 more
Caused by: org.apache.catalina.LifecycleException: java.lang.InterruptedException
    at org.apache.catalina.core.StandardContext.stopInternal(StandardContext.java:5487)
    at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:230)
    ... 16 more
Caused by: java.lang.InterruptedException
    at java.lang.Object.wait(Native Method)
    at java.lang.Thread.join(Thread.java:1186)
    at java.lang.Thread.join(Thread.java:1239)
    at org.apache.catalina.core.StandardContext.stopInternal(StandardContext.java:5484)
    ... 17 more

Ticket History (3/3 Histories)

2011-09-11 18:12 Updated by: shinsuke
  • New Ticket "終了時にcatalina.outにExceptionが発生する" created
2011-09-19 21:16 Updated by: shinsuke
Comment

Exceptionが出なくなったが、以下のエラーが出る。

2011/09/19 21:13:10 org.apache.catalina.loader.WebappClassLoader clearReferencesThreads
致命的: The web application [/fess] appears to have started a thread named [chronos-pool-1-daemonthread-1] but has failed to stop it. This is very likely to create a memory leak.
2011/09/19 21:13:10 org.apache.catalina.loader.WebappClassLoader clearReferencesThreads
致命的: The web application [/fess] appears to have started a thread named [MultiThreadedHttpConnectionManager cleanup] but has failed to stop it. This is very likely to create a memory leak.
2011/09/19 21:13:10 org.apache.catalina.loader.WebappClassLoader clearReferencesThreads
致命的: The web application [/fess] appears to have started a thread named [chronos-pool-1-daemonthread-3] but has failed to stop it. This is very likely to create a memory leak.
2011/09/19 21:13:10 org.apache.catalina.loader.WebappClassLoader clearReferencesThreads
致命的: The web application [/fess] appears to have started a thread named [chronos-pool-3-thread-2] but has failed to stop it. This is very likely to create a memory leak.


2011-09-29 21:26 Updated by: shinsuke
  • Resolution Update from None to Fixed
  • Status Update from Open to Closed
  • Ticket Close date is changed to 2011-09-29 21:26

Attachment File List

No attachments

Edit

Please login to add comment to this ticket » Login