Ticket #41758

lib-*.m4 not up to date with gettext-0.21

Open Date: 2021-03-13 14:21 Last Update: 2021-04-03 04:31

Reporter:
Owner:
Type:
Status:
Closed
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
4

Details

Our bootstrap is supposed to be up-to-date with gettext-0.21 (and patches to go beyond on review/on works). We've missed m4/lib-*.m4 files when updating to gettext-0.21 level.

We were supposed to be on gettext-0.21 level in 2.6.3 already, and there has been no problems reported because of the older lib-*.m4 files, so supposedly this is not critical - not something that still needs to be fixed in upcoming 3.0.0-beta1 and 2.6.4 releases.

Ticket History (3/13 Histories)

2021-03-13 14:21 Updated by: cazfi
  • New Ticket "lib-*.m4 not up to date with gettext-0.21" created
2021-03-13 14:31 Updated by: cazfi
  • Resolution Update from None to Accepted
2021-03-15 08:47 Updated by: cazfi
Comment

Pushed to master & S3_1

2021-03-20 10:43 Updated by: cazfi
Comment

Pushed also to S3_0, leaving only S2_6

2021-03-21 17:28 Updated by: cazfi
  • Resolution Update from Accepted to Out of Date
Comment

For S2_6 the current patch causes #41819 - host-cpu-c-abi.m4 should also be added when updating lib-ld.m4.

2021-03-22 22:26 Updated by: cazfi
  • Resolution Update from Out of Date to Accepted
Comment

Added S2_6 version that adds host-cpu-c-abi.m4

2021-03-24 08:09 Updated by: cazfi
Comment

#41843 started when this was pushed.

2021-03-26 03:22 Updated by: cazfi
Comment

S2_6 version that does not introduce #41843 to the branch.

2021-04-03 04:31 Updated by: cazfi
  • Status Update from Open to Closed
  • Owner Update from (None) to cazfi
  • Resolution Update from Accepted to Fixed

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login