Ticket #41870

Threaded AI does not build

Open Date: 2021-03-29 16:53 Last Update: 2021-03-31 09:05

Reporter:
Owner:
Type:
Status:
Closed
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
1

Details

In a round of build tests before 2.6.4 release S2_6 build with threaded AI enabled failed.

Ticket History (3/7 Histories)

2021-03-29 16:53 Updated by: cazfi
  • New Ticket "Threaded AI does not build" created
2021-03-29 16:59 Updated by: cazfi
Comment

In file included from ../../../../src/ai/threaded/threadedai.c:27:

../../../../src/ai/default/aiplayer.h: In function ‘def_ai_city_data’:

../../../../src/ai/default/aiplayer.h:44:28: error: implicit declaration of function ‘city_ai_data’; did you mean ‘unit_ai_data’? -Werror=implicit-function-declaration

44 | return (struct ai_city *)city_ai_data(pcity, deftype);
| ~
| unit_ai_data

../../../../src/ai/default/aiplayer.h:44:28: error: nested extern declaration of ‘city_ai_data’ -Werror=nested-externs

../../../../src/ai/default/aiplayer.h:44:10: error: cast to pointer from integer of different size -Werror=int-to-pointer-cast

44 | return (struct ai_city *)city_ai_data(pcity, deftype);
|

In file included from ../../../../src/ai/default/aisettler.h:21,

from ../../../../src/ai/threaded/threadedai.c:28:

../../../../src/common/city.h: At top level:

../../../../src/common/city.h:767:7: error: conflicting types for ‘city_ai_data’

767 | void *city_ai_data(const struct city *pcity, const struct ai_type *ai);
| ~

In file included from ../../../../src/ai/threaded/threadedai.c:27:

../../../../src/ai/default/aiplayer.h:44:28: note: previous implicit declaration of ‘city_ai_data’ was here

44 | return (struct ai_city *)city_ai_data(pcity, deftype);
| ~

cc1: all warnings being treated as errors

2021-03-29 17:03 Updated by: cazfi
Comment

S2_6 and S3_0 affected. Master seem to work.

2021-03-29 17:21 Updated by: cazfi
  • Resolution Update from None to Accepted
2021-03-29 17:24 Updated by: cazfi
Comment

Was a regression caused by hrm #905143 - 2.6.3 not affected, 3.0.0-beta1 affected.

2021-03-31 09:05 Updated by: cazfi
  • Status Update from Open to Closed
  • Owner Update from (None) to cazfi
  • Resolution Update from Accepted to Fixed

Attachment File List

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login