Ticket #41890

tcc: Requires return values even after exit() calls

Open Date: 2021-03-31 12:01 Last Update: 2021-04-13 06:20

Reporter:
Owner:
Type:
Status:
Closed
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
3

Details

I got a working tcc compiler again. Common problem with that new version is that it would expect functions to return value even after there's been exit() call.

Not considering these failures with tcc a 2.6.4 release blocker, as they are not a regression since 2.6.3 and tcc setup has not worked for some time. Try to fix things to 2.6.5.

Ticket History (3/8 Histories)

2021-03-31 12:01 Updated by: cazfi
  • New Ticket "tcc: Requires return values even after exit() calls" created
2021-04-07 09:25 Updated by: cazfi
  • File 0033-tcc-Return-value-even-after-exit-call.patch (File ID: 6427) is attached
2021-04-07 09:25 Updated by: cazfi
  • File 0033-tcc-Return-value-even-after-exit-call.patch (File ID: 6427) is deleted
2021-04-07 09:26 Updated by: cazfi
  • Resolution Update from None to Accepted
2021-04-13 06:20 Updated by: cazfi
  • Status Update from Open to Closed
  • Owner Update from (None) to cazfi
  • Resolution Update from Accepted to Fixed

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login