Ticket #42166

Allied AI worker changed my forest

Open Date: 2021-05-04 15:45 Last Update: 2021-05-19 10:16

Reporter:
Owner:
(None)
Type:
Status:
Closed
Component:
MileStone:
(None)
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Invalid
File:
3

Details

3.0.beta 1

A worker (id_3573) from an allied nation, changed my forest to a grassland (or a plain). I don't wan't this i want production not food :-)

Maybe we should allow working on allied tiles only to add road/rails or irrigation but not changing the terrain (i often improve my allied road/rail system to compensate AI incapacity to build long distance coherent transport system, for example one main railway from one end to the other end of the territory)

Ticket History (3/12 Histories)

2021-05-04 15:45 Updated by: alain_bkr
  • New Ticket "Allied AI worker changed my forest" created
2021-05-14 05:02 Updated by: chippo
Comment

For completely unknown reasons, I can't load either of your savegames. The files seem fine - I can xzcat them and they look much like my savegame files.

But anways, this tile that the allied worker was working - was it perhaps within range of one of the ally's cities, even though it was (I presume) within your nation border?

2021-05-14 09:31 Updated by: alain_bkr
Comment

(i had problem for loading a game and changing its language : LANG=en freeciv-gtk3.22 sometimes does not work, connection lost or something alike , but LANGUAGE=en freeciv_gtk3.22 does !)

Yes , the tile is inside my nation border, but within range of ally's city.

I just noticed it because, i was scrutinizing my 'autoworkers' previously, and they were crazy : they sometimes suppressed forest instead of doubling irrigation for supermarkets.

2021-05-15 02:37 Updated by: cazfi
Comment

Reply To chippo

For completely unknown reasons, I can't load either of your savegames. The files seem fine - I can xzcat them and they look much like my savegame files.

This almost sounds like a very serious bug. Both load fine for me. Do you try to load them directly from client? Can you try to load them to separately run server (with '-f <filename>' command line parameter) to see what the server error message is?

Are your own savegames .xz or .bz2 compressed? If latter, your server probably lacks xz support.

2021-05-15 17:31 Updated by: chippo
Comment

Reply To cazfi

This almost sounds like a very serious bug. Both load fine for me. Do you try to load them directly from client? Can you try to load them to separately run server (with '-f <filename>' command line parameter) to see what the server error message is?

The server loads the game fine. It looks just like when I load one of my own games. I didn't use the '-f <fn>' option, I typed 'load' at the server's command prompt and used readline file completion to get to the file.

Are your own savegames .xz or .bz2 compressed? If latter, your server probably lacks xz support.

Nope. My own savegames have .xz, and I put in some effort to find exactly which packages a completely new ubuntu installation needs to compile freeciv and every single toy and tool and feature that comes with it. To get .xz compression, you need to install liblzma-dev.

I didn't put in a bug report because it seemed to me that I didn't know what I was doing (or that Alain was doing something interesting/weird). What happens is:

In the qt client, I Browse to Alain's savegame. I click on it and get the start screen (to be attached soon). I can see his name and what side he's playing. But the Start button doesn't get a blue border around it when you mouse-over it and it does nothing when you click it. Clicking Disconnnect works as expected.

2021-05-18 01:35 Updated by: kvilhaugsvik
Comment

Reply To chippo

In the qt client, I Browse to Alain's savegame. I click on it and get the start screen (to be attached soon). I can see his name and what side he's playing. But the Start button doesn't get a blue border around it when you mouse-over it and it does nothing when you click it. Clicking Disconnnect works as expected.

You need to take alain (probably right click) or to change your user name to alain when logging into the server.

2021-05-18 17:42 Updated by: chippo
Comment

Reply To kvilhaugsvik

You need to take alain (probably right click) or to change your user name to alain when logging into the server.

That worked.

@alain: To tell us about a particular tile, (on my keyboard) you press ctrl-alt-right-click and then you get a tag in chat which looks like this: [l tgt="unit" id=3573 name="Workers" /] . If we cut'n'paste that tag into chat and press enter, we get a highlighted box around the tile.

As to the issue, 'cos it's within your ally's city's range, the ally could always be planning for his city to outgrow yours and to take over that tile. I don't think that this is a bug and that the ticket can be closed.

2021-05-19 10:15 Updated by: alain_bkr
Comment

1/ thanks for the tip (ctrl-alt-rightclick) + l tgt="unit" id=3573 name="Workers" /

2/ your explanations are clear , it is a feature not a bug.

2021-05-19 10:16 Updated by: alain_bkr
  • Status Update from Open to Closed
  • Resolution Update from None to Invalid

Attachment File List

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login