Ticket #42172

autogame : autosave QUITTILD|GAMEOVER does not behave as i expected

Open Date: 2021-05-04 17:46 Last Update: 2021-11-17 14:46

Reporter:
Owner:
Type:
Status:
Closed
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
2

Details

I expected "set autosave QUITTILDE|GAMEOVER" to save the last turn of an autogame with N turns.

It is not the case, nothing is saved.

It is easy to workaround , so maybe not urgent to fix

set endturn 10   # my 10 turn game

set autosave  TURN|QUITTILDE|GAMEOVER
set saveturns  10  # for my 10 turns game

Ticket History (3/7 Histories)

2021-05-04 17:46 Updated by: alain_bkr
  • New Ticket "autogame : autosave QUITTILD|GAMEOVER does not behave as i expected" created
2021-05-04 18:04 Updated by: cazfi
Comment

GAMEOVER saving logic probably always thinks that an autogame (with no humans connected) ended with quitidle

&& conn_list_size(game.est_connections) > 0) {
/* Save game on game_over, but not when the gameover was caused by
      • the -q parameter. */

QUITIDLE saving on the other hand knows that it was not the case..

2021-05-14 04:07 Updated by: alain_bkr
Comment

my mistake : I forgot an 's' , and added comments after the parameters which is not allowed.

But, the game is not saved after interrupt (CTRL-C twice)

set autosaves TURN|GAMEOVER|QUITIDLE|INTERRUPT

(Edited, 2021-05-14 04:11 Updated by: alain_bkr)
2021-11-11 11:18 Updated by: cazfi
  • Resolution Update from None to Accepted
  • Milestone Update from (None) to 2.6.6 (closed)
2021-11-17 14:46 Updated by: cazfi
  • Status Update from Open to Closed
  • Owner Update from (None) to cazfi
  • Resolution Update from Accepted to Fixed

Attachment File List

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login