Ticket #42271

dependencies/*/Version conflicting with OSX system header

Open Date: 2021-05-15 14:21 Last Update: 2021-05-20 23:56

Reporter:
Owner:
Type:
Status:
Closed
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
3

Details

Dean reports in https://www.freelists.org/post/freeciv-dev/OSX-Qt61-configure-failing,3 that OSX headers trying to include file called "version" end up failing because of "dependencies/tinycthread/Version".

To work around that, rename "dependencies/*/Version" as Version.txt

Ticket History (3/6 Histories)

2021-05-15 14:21 Updated by: cazfi
  • New Ticket "dependencies/*/Version conflicting with OSX system header" created
2021-05-15 14:35 Updated by: cazfi
  • Resolution Update from None to Accepted
2021-05-20 23:56 Updated by: cazfi
  • Status Update from Open to Closed
  • Owner Update from (None) to cazfi
  • Resolution Update from Accepted to Fixed

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login