Ticket #42338

civ2civ3: missing req for actionenabler_build_city_pioneer

Open Date: 2021-05-21 06:28 Last Update: 2021-07-05 01:52

Reporter:
Owner:
(None)
Type:
Status:
Closed
Component:
MileStone:
(None)
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Works For Me
File:
None

Details

I opened the ticket again...

It seems the req is missing in v3.0 but not in master:

"TerrainFlag", "NoCities", "Local", FALSE
[actionenabler_build_city_pioneer]
...
target_reqs    =
    { "type",   "name", "range", "present"
      "CityTile", "Claimed", "Local", FALSE
    }

[actionenabler_build_city_domestic]
...
target_reqs    =
    { "type",        "name",     "range", "present"
      "CityTile",    "Claimed",  "Local", TRUE
      "TerrainFlag", "NoCities", "Local", FALSE
    }

Ticket History (3/11 Histories)

2021-05-21 06:28 Updated by: bard
  • New Ticket "civ2civ3: missing req for actionenabler_build_city_pioneer" created
2021-05-21 06:42 Updated by: bard
  • Details Updated
2021-05-21 06:45 Updated by: bard
  • Status Update from Open to Closed
  • Details Updated
2021-05-21 06:55 Updated by: bard
  • Status Update from Closed to Open
  • Component Update from Ruledit to Rulesets
  • Details Updated
2021-05-21 07:08 Updated by: bard
Comment

The bug (missing req) seems to affect to all rulesets in S3_0, but it was already fixed in S3_1 and master.

2021-05-21 07:21 Updated by: kvilhaugsvik
Comment

It is an obligatory hard requirement in master. In 3.0 it is a hard requirement but explicitly adding it to each enabler isn't obligatory.

Adding it explicitly is a good idea. There could be logic reasoning about action enablers that isn't aware of the hard requirement.

2021-05-21 09:22 Updated by: bard
Comment

Ah, I see. I just confirmed that cities in v3.0 can't be build on terrains with "NoCities" flag. I found it confusing that it was working right without the need of the requirement. I edited the ticket several times because I was unsure if I was testing it wrong.

Is there a way to differentiate, from the point of view of a ruleset editor, which requirements are hardcoded? I mean those that the rule editor might remove/edit without affecting the game at all. I guess the current job to make action enablers modable is hard enough, and I don't want to complicate it, so no request here if there is no way.

I'm starting to understand the meaning of this thread of yours: http://forum.freeciv.org/f/viewtopic.php?f=15&t=91859, that I read some time ago, but I admit I did not understand at the time.

2021-05-21 09:47 Updated by: cazfi
Comment

Reply To bard

Is there a way to differentiate, from the point of view of a ruleset editor, which requirements are hardcoded?

Only by checking the doc/README.actions document, I guess.

2021-05-21 15:16 Updated by: kvilhaugsvik
Comment

Reply To bard

Is there a way to differentiate, from the point of view of a ruleset editor, which requirements are hardcoded? I mean those that the rule editor might remove/edit without affecting the game at all. I guess the current job to make action enablers modable is hard enough, and I don't want to complicate it, so no request here if there is no way.

Reeading doc/README.actions, as Marko said. I considered adding support for warnings for hard requirements discovered to be expressible in the requirement vector system after data file format freeze but haven't prioritize working on it.

(Edited, 2021-05-21 15:17 Updated by: kvilhaugsvik)
2021-07-05 01:51 Updated by: bard
Comment

Reply To kvilhaugsvik

Reeading doc/README.actions, as Marko said. I considered adding support for warnings for hard requirements discovered to be expressible in the requirement vector system after data file format freeze but haven't prioritize working on it.

Thanks, the readme.actions is very good, all the relevant info is there. I also wanted to thank you for this new action enabler system, it is pretty well done, and it brings freeciv modability to a whole new level.

I guess this ticket can be closed, since it is not really a bug.

2021-07-05 01:52 Updated by: bard
  • Status Update from Open to Closed
  • Resolution Update from None to Works For Me

Attachment File List

No attachments

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login