Ticket #42409

Freeciv crashes

Open Date: 2021-05-29 08:16 Last Update: 2021-06-01 12:18

Reporter:
Owner:
Type:
Status:
Closed
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
2

Details

Hello, my freeciv-gtk crashes when ending a turn. Here are the details:

Freeciv version 2.6.4 gui-gtk-3.0

1: Lost connection to server: read error.

1: in genhash_lookup() [genhash.c::689]: assertion '((void *)0) != pgenhash' failed.

1: Please report this message at https://osdn.net/projects/freeciv/ticket/

1: in genhash_lookup() [genhash.c::689]: assertion '((void *)0) != pgenhash' failed.

1: Please report this message at https://osdn.net/projects/freeciv/ticket/

1: in genhash_lookup() [genhash.c::689]: assertion '((void *)0) != pgenhash' failed.

1: Please report this message at https://osdn.net/projects/freeciv/ticket/

Segmentation fault (core dumped)

If you need anything, like the savegame, I can provide it.

Best regards,

Andrea

Ticket History (3/13 Histories)

2021-05-29 08:16 Updated by: kontorotsui
  • New Ticket "Freeciv crashes" created
2021-05-29 08:17 Updated by: kontorotsui
  • Details Updated
2021-05-29 09:29 Updated by: cazfi
Comment

Is the problem reproducible from the savegame? If yes, please attach the savegame.

2021-05-29 18:16 Updated by: kontorotsui
Comment

Absolutely consistent.

Load the attached savefile, click "turn done" and it booms.

2021-05-29 19:30 Updated by: chippo
Comment

Reply To kontorotsui

Load the attached savefile, click "turn done" and it booms.

Not for me, it doesn't. Clicked 'turn done' a few times and no crash or any unusual messages on both client and server.

So, we need to ask you what operating system are you using and which version of freeciv it was.

2021-05-29 19:31 Updated by: chippo
Comment

Reply To chippo

So, we need to ask you what operating system are you using and which version of freeciv it was.

Sorry, you did report the freeciv version.

2021-05-29 19:48 Updated by: cazfi
Comment

I can reproduce and backtrace shows SIGFPE (likely division by zero) at daidiplomacy.c:333

That is:

int limit = MAX(1, player_tech_upkeep(pplayer)
/ research->techs_researched);
2021-05-29 19:54 Updated by: chippo
Comment

Reply To chippo

Sorry, you did report the freeciv version.

I, too, get the coredump in S2_6 (I was looking with S3_0 when I had no problem). I didn't have debugging to give a good bt, so I'm busy building that now.

2021-05-29 20:17 Updated by: cazfi
  • Resolution Update from None to Accepted
  • Milestone Update from (None) to 2.6.5 (closed)
  • Component Update from (None) to AI
2021-05-29 20:27 Updated by: chippo
Comment

The patch works for me. No more core dump.

2021-06-01 12:18 Updated by: cazfi
  • Status Update from Open to Closed
  • Owner Update from (None) to cazfi
  • Resolution Update from Accepted to Fixed

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login