Ticket #42558

civ2civ3: improve readme

Open Date: 2021-06-22 04:33 Last Update: 2021-07-19 08:18

Reporter:
Owner:
Type:
Status:
Closed
Component:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
3

Details

I have been trying to improve a bit the readme of civ2civ3:

- Reserve the use of capital letters to words used as rule_names: units, techs, terrains, resources, buildings, governments, and some key game concepts like Food/Trade/Production, Science/Gold/Luxury, Shields/Bulbs/Coins...

- Use "Production" instead of "Shields" for city output (as in the city UI), or for production of citizens (like Trade, Luxury, Science and Gold), that will be multiplied by buildings.

- Keep using "Shields" for upkeep of units, use "Coins" instead of "Gold" for upkeep of units or buildings, and use "Bulbs" instead of "Science" for upkeep of techs.

This way, +1 Gold could mean +3 Coins if you have all economic buildings; +1 Production up to +2 Shields with all production buildings; +1 Science up to +4 Bulbs due to buildings and wonders.

However, +1 Shield, or Coin, or Bulb for upkeep of units, buildings, or techs will always remain +1.

- Use "upkeep in Food", instead of "Food upkeep". I'm not sure if better or not?

- Use "ground units" when they include all Land unit classes (big and small). Use "naval units" or "boats" when they include both Sea and Trireme.

- Use "unhappiness caused by military units", instead of Military Unhappiness, or simply war unhappiness.

- Clarify when wonders affect every city of every player, or only the cities of the owner.

I'm still working on it, so I'd thank other suggestions. If you have noticed that I use to repeat the same mistakes while I write on english, it is a good moment to point it. It will make things easier for future updates of the readme or the helptexts. I already took note of the "same as" instead of "same than" fix.

Ticket History (3/24 Histories)

2021-06-22 04:33 Updated by: bard
  • New Ticket "civ2civ3: improve readme" created
2021-06-23 03:02 Updated by: bard
  • File README.civ2civ3-S3_0-WIP (File ID: 7117) is attached
2021-06-23 03:26 Updated by: bard
Comment

Uploaded wip version for S3_0, where text is not wrapped.

Before I make the patches, I'd like to ask if it would be possible to keep this readme file unwrapped. I have seen that both clients qt and gtk include an auto-wrap feature when the readme is shown in game, that get a better result (imo) than manually wrapping it, specially when the window size is smaller than the line size of the manual wrap. It is also much easier (imo) to edit the file, and to compare it to other versions, when the text is not wrapped.

In that case, I'd make a patch to unwrap the text, another for the text changes, and a 3th patch to rearrange some parts, so it is easier to compare them.

Else, if text must be wrapped, I'd like to ask if you use some automatic tool for this kind of readme files?

(Edited, 2021-06-25 05:54 Updated by: bard)
2021-06-25 05:28 Updated by: bard
  • File README.civ2civ3-S3_0-WIP (File ID: 7117) is deleted
2021-06-25 05:29 Updated by: bard
  • File README.civ2civ3-S3_0-wrapped (File ID: 7123) is attached
2021-06-25 05:29 Updated by: bard
  • File README.civ2civ3-S3_0-unwrapped (File ID: 7124) is attached
2021-06-25 05:52 Updated by: bard
Comment

I made a wrapped version. Uploaded both .txt files for comparison.

The unwrapped version would make my life easier because I use this readme file continually to keep track of all my WIP changes that I test, modify, and revert dozens of times for each single patch that I upload. I also use it for 3 columns diff comparison where my windows are smaller than 60 chars and the fixed wrap (to 80 chars) is not a help.

Anyway, if I don't get any answer, I'll make the patches with the wrapped version. I found an automatic tool to get a similar result as the previous version made by jtn (that I like):

1) linux command: fold -s -w 75

2) use kate (or similar editor) to replace the final space of each line " \n" by a double space in the new line "\n "

2021-06-25 08:19 Updated by: bard
  • File m-30-civ2civ3-Try-to-improve-the-readme-of-civ2civ3.patch (File ID: 7129) is attached
2021-06-25 08:32 Updated by: bard
Comment

Uploaded patch. It includes fix to bug reported here #42468.

This patch won't apply on v2.6. I guess it is better if we don't change the wording of the readme in the middle of the game for people already playing 2.6. I'll use that other ticket to make a patch for 2.6 that just fixes bugs or wrong descriptions, without altering the format nor the wording.

2021-06-30 05:12 Updated by: bard
  • File README.civ2civ3-S3_0-wrapped (File ID: 7123) is deleted
2021-06-30 05:12 Updated by: bard
  • File README.civ2civ3-S3_0-unwrapped (File ID: 7124) is deleted
2021-06-30 05:13 Updated by: bard
  • File m-30-Try-to-improve-the-readme-of-civ2civ3-v2.patch (File ID: 7142) is attached
2021-06-30 05:13 Updated by: bard
  • File m-30-civ2civ3-Try-to-improve-the-readme-of-civ2civ3.patch (File ID: 7129) is deleted
2021-06-30 05:28 Updated by: bard
Comment

Uploaded new patch (v2) where wrapping is not modified for paragraphs where texts was not modified.

Paragraphs where text was altered have been wrapped using linux command: fold -s -w 72. (more similar to jtn version).

I plan to make other patches for civ2civ3, and I'd like to use this patched readme as base (so they do not collide later). Please, let me know if you plan to commit this patch, and for which versions.

2021-06-30 05:42 Updated by: bard
  • File m-30-Try-to-improve-the-readme-of-civ2civ3-v2.patch (File ID: 7142) is deleted
2021-06-30 06:07 Updated by: bard
Comment

Uploaded new version (v3) because previous one was changing the file mode: mode change 100644 => 100755 data/civ2civ3/README.civ2civ3

I didn't know git included file permissions in the patches, I'll take it into account in the future.

2021-06-30 15:03 Updated by: cazfi
Comment

Reply To bard

Please, let me know if you plan to commit this patch, and for which versions.

I'm taking it a bit easier with freeciv development at the moment, but this ticket definitely is in my TODO. Probably getting back to full steam in August.

2021-07-01 06:05 Updated by: bard
Comment

Reply To cazfi

I'm taking it a bit easier with freeciv development at the moment, but this ticket definitely is in my TODO. Probably getting back to full steam in August.

It's ok, no hurry, your usual work pace looks insane to me. I understand that you slow down from time to time.

I plan to do some more patches for civ2civ3 and I wanted to do them dependant on this one, but I wasn't sure. Thanks for the answer.

(Edited, 2021-07-05 01:54 Updated by: bard)
2021-07-09 13:10 Updated by: cazfi
  • Owner Update from (None) to cazfi
  • Resolution Update from None to Accepted
  • Milestone Update from (None) to 3.0.0-beta3 (closed)
2021-07-11 07:02 Updated by: cazfi
  • Status Update from Open to Closed
  • Resolution Update from Accepted to Fixed
2021-07-19 08:18 Updated by: bard
Comment

Thank you. I'm still testing civ2civ3 under v3.0, but soon I'll try to make the other patches I was talking about.

Attachment File List

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login