Ticket #42885

Disable -Warray-bounds

Open Date: 2021-09-20 06:52 Last Update: 2021-09-24 19:44

Reporter:
Owner:
Type:
Status:
Closed
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
3

Details

gcc-12 development version gives an array-bounds warning about techtools.c code. I reported that to gcc bugtracker ( https://gcc.gnu.org/bugzilla/show_bug.cgi?id=102405 ), but the report was deemed invalid; compiler does not have enough information to know that the warning is baseless so they consider it ok to show. Unfortunately I don't see any sensible way to rework the code so that it would not trigger the warning, and -Werror (which we use in development with --enable-debug) turns it to an error. The only solution seems to be to disable -Warray-bounds warnings completely.

Ticket History (3/6 Histories)

2021-09-20 06:52 Updated by: cazfi
  • New Ticket "Disable -Warray-bounds" created
2021-09-20 08:37 Updated by: cazfi
  • Resolution Update from None to Accepted
2021-09-24 19:44 Updated by: cazfi
  • Status Update from Open to Closed
  • Owner Update from (None) to cazfi
  • Resolution Update from Accepted to Fixed

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login