Ticket #43001

freeciv-ruleup bug with ExplorerStartUnit

Open Date: 2021-10-09 13:54 Last Update: 2021-11-04 15:01

Reporter:
Owner:
Type:
Status:
Closed
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
3

Details

In units.ruleset, roles = "ExplorerStartUnit" gets turned into roles = "ExplorerStartunit", and the case sensitive causes it to stop working.

Ticket History (3/12 Histories)

2021-10-09 13:54 Updated by: ddeanbrown
  • New Ticket "freeciv-ruleup bug with ExplorerStartUnit" created
2021-10-09 14:08 Updated by: cazfi
Comment

You're right that there's inconsistency in that internal string seems to be "ExplorerStartunit" (and similar for all other "XxxStartunit"), while supplied rulesets have "ExplorerStartUnit". However, I fail to see where is that case sensitive, causing it to fail, and even more surprisingly so that the *internal* string fails and not that in the rulesets.

2021-10-09 20:02 Updated by: cazfi
Comment

Did you actually encounter such a failure, or did you just assume the handling to be case sensitive? If you had a failure, can you give instructions how to reproduce it?

2021-10-10 04:33 Updated by: ddeanbrown
Comment

Should add this is 3.0.0-beta2. I'm updating my custom ruleset from 2.6 to 3.0, used freeciv-ruleup. At run time I didn't get expected Explorer start unit, figured out that ExplorerStartunit in units.ruleset was the cause, replaced that with ExplorerStartUnit and it worked OK. Further testing shows that then changing it back to ExplorerStartunit doesn't break it. This is weird. Tried same sequence with DiplomatStartunit and same thing happened, first it fails, changing to DiplomatStartUnit makes it work, change it back to DiplomatStartunit and it still works.

2021-10-12 12:57 Updated by: ddeanbrown
Comment

Since it was weird, tried a bunch of additional testing and could not repro. Now I'm thinking it was a random glitch on my part and not a real bug.

2021-10-12 12:57 Updated by: ddeanbrown
  • Status Update from Open to Closed
  • Resolution Update from None to Invalid
2021-10-12 13:53 Updated by: cazfi
  • Status Update from Closed to Open
  • Resolution Update from Invalid to None
  • Component Update from (None) to General
  • Details Updated
Comment

There's still the inconsistency between internal flag names and ones used in the supplied rulesets, which I'd want to fix.

2021-10-17 23:10 Updated by: cazfi
  • Resolution Update from None to Accepted
  • Milestone Update from (None) to 3.0.0 (closed)
  • Details Updated
Comment

Not yet sure if it should go to S3_0, or only to later branches.

Attached patches even for S3_0. In some cases these strings end end-user readable in the help system.

2021-11-04 15:01 Updated by: cazfi
  • Status Update from Open to Closed
  • Owner Update from (None) to cazfi
  • Resolution Update from Accepted to Fixed

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login