Ticket #43145

wrong help text shown

Open Date: 2021-10-28 09:01 Last Update: 2021-11-08 12:54

Reporter:
Owner:
Type:
Status:
Closed
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
2

Details

3.0.0-beta3
Bug in file helpdata.c, routine helptext_extra(), line 3652, the block starting with

if (territory_claiming_base(pbase)) {

looks wrong, maybe it should not be there. There's a similar block starting with the same if() starting at line 3689 that looks like the correct one.

Ticket History (3/11 Histories)

2021-10-28 09:01 Updated by: ddeanbrown
  • New Ticket "wrong help text shown" created
2021-10-30 21:12 Updated by: cazfi
Comment

Skipping technical explanation why it is so, I just say that "territory claiming base" = "ownable base". The code in question seems correct to me, but could use a comment clarifying it -> I assume this ticket will be resolved by adding such a comment.

2021-10-31 02:35 Updated by: ddeanbrown
Comment

Adding a screen shot to show what the message looks like in context, where it doesn't make sense. I now think the problem is that it needs to be re-worded to say "Units of a nation at war with the nation that currently owns it can be captured by such units."

2021-10-31 02:47 Updated by: cazfi
Comment

Reply To ddeanbrown

Adding a screen shot to show what the message looks like in context, where it doesn't make sense. I now think the problem is that it needs to be re-worded to say "Units of a nation at war with the nation that currently owns it can be captured by such units."

Negative. It's the base itself that gets captured (so it starts to claim terrain for the new owner)

2021-10-31 03:03 Updated by: ddeanbrown
Comment

Ah - now I understand. Not sure if it's my stupidity or maybe the message needs to be clearer - "Base can be captured..."

2021-11-02 14:34 Updated by: cazfi
Comment

Later branches have this part of code reworked. One thing we could backport is changing word "captured" to "conquered". Would that make it clearer?

2021-11-03 03:27 Updated by: ddeanbrown
Comment

Yes, thanks. In the context with all the mentions of "units", "captured" made me think of capturing units, which doesn't make sense.

2021-11-03 07:45 Updated by: cazfi
  • Resolution Update from None to Accepted
2021-11-08 12:54 Updated by: cazfi
  • Status Update from Open to Closed
  • Owner Update from (None) to cazfi
  • Resolution Update from Accepted to Fixed

Attachment File List

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login