Ticket #43643

Recycle Unit, wrong message when Help Build Wonder is legal

Open Date: 2022-01-17 10:58 Last Update: 2022-01-26 09:44

Reporter:
Owner:
Type:
Status:
Closed
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
1

Details

City building a wonder, caravan to move while on adjacent tile, choose Unit -> Go to and... -> Recycle Unit, direct it to the city. Get 2 messages, 1st is "Caravan could not do Recycle Unit to (26,77).", which is correct. 2nd is "Your Caravan can't do Help Build Wonder when Help Build Wonder is legal.", which is not correct.

Ticket History (3/7 Histories)

2022-01-17 10:58 Updated by: ddeanbrown
  • New Ticket "Recycle Unit, wrong message when Help Build Wonder is legal" created
2022-01-17 14:04 Updated by: cazfi
Comment

Which version, and which ruleset? I can't reproduce with the default (civ2civ3) ruleset, neither in master nor S3_0. Master gives just one, correct, message. In S3_0 the action success.

2022-01-17 14:32 Updated by: ddeanbrown
Comment

3.0.0b3, my custom ruleset. Tried with default (civ2civ3) ruleset and a Freight, got slightly different results. 2nd message was "Your Freight can't do when Help Build Wonder is legal." Difference is message settings. I had changed "Error message from bad command" to show in message window.

2022-01-17 16:28 Updated by: cazfi
Comment

Other bugs I encountered made this hard to reproduce, but I think I now know know what's wrong with the message.

2022-01-18 12:09 Updated by: cazfi
  • Resolution Update from None to Accepted
  • Milestone Update from (None) to 3.0.0 (closed)
2022-01-26 09:44 Updated by: cazfi
  • Status Update from Open to Closed
  • Owner Update from (None) to cazfi
  • Resolution Update from Accepted to Fixed

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login