Ticket #43942

Qt6 as the default also in S3_1

Open Date: 2022-02-20 12:14 Last Update: 2022-03-14 15:02

Reporter:
Owner:
Type:
Status:
Closed
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
3

Details

Qt6 has gone in to the Debian Unstable - expected to migrate to testing in a couple of days. Also Ubuntu has picked that immediately, so it seems that Ubuntu-22.04 LTS will have it after all. With most current systems then having Qt6, we should consider making it the default also in S3_1 already (I think we definitely want to make it the default before releasing 3.1.0, which is still years away)

Ticket History (3/8 Histories)

2022-02-20 12:14 Updated by: cazfi
  • New Ticket "Qt6 as the default also in S3_1" created
2022-02-21 21:03 Updated by: cazfi
Comment

Before this, I'd like #43958 to be in (doing it the other way around may cause some people to note the "Qt6 requirement", and to never look at it again)

2022-03-02 08:24 Updated by: cazfi
  • Owner Update from (None) to cazfi
  • Resolution Update from None to Accepted
Comment

Change to S3_1 attached, and also a patch for master that changes README.packaging accordingly.

2022-03-06 03:19 Updated by: cazfi
Comment

- Rebased master patch to apply on top of (more urgent) #44018

2022-03-14 15:02 Updated by: cazfi
  • Status Update from Open to Closed
  • Resolution Update from Accepted to Fixed

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login