Ticket #44131

autogen.sh: "Illegal number"

Open Date: 2022-03-17 11:20 Last Update: 2022-03-19 07:07

Reporter:
Owner:
Type:
Status:
Closed
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
1

Details

Running build test set (S3_1) on Ubuntu-22.04 development version prints out "Illegal number" errors from autogen.sh.

This is most likely some version number in the system containing non-numeral part that autogen.sh regardless tries to treat as number.

Ticket History (3/6 Histories)

2022-03-17 11:20 Updated by: cazfi
  • New Ticket "autogen.sh: "Illegal number"" created
2022-03-17 12:10 Updated by: cazfi
Comment

It comes when checking python3 version that is "3.10.2+", and it's that "2+" that it's complaining about.

2022-03-17 12:21 Updated by: cazfi
  • Owner Update from (None) to cazfi
  • Resolution Update from None to Accepted
  • Milestone Update from (None) to 3.0.1 (closed)
Comment

Will push even to S2_6

2022-03-18 05:34 Updated by: cazfi
Comment

As we don't check python version number in S3_0, this is not currently breaking build on that branch -> no need to "emergency" freeciv-3.0 release.

2022-03-19 07:07 Updated by: cazfi
  • Status Update from Open to Closed
  • Resolution Update from Accepted to Fixed

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login