Ticket #44176

click on shady tile doesn't show resource

Open Date: 2022-03-25 04:50 Last Update: 2022-04-07 12:00

Reporter:
Owner:
Type:
Status:
Closed
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
2

Details

3.0.0

"shady tile" meaning a tile that has been seen before (darker but not black) but is not currently live visible (lighter). When you center mouse click on it to get the tile info, it ignores any resources - doesn't list it and the numbers are wrong.

Seen with both gtk3 and qt clients. Works as expected in 2.6.6

Ticket History (3/12 Histories)

2022-03-25 04:50 Updated by: ddeanbrown
  • New Ticket "click on shady tile doesn't show resource" created
2022-03-25 05:19 Updated by: cazfi
Comment

I cannot produce (in S3_0 HEAD - haven't gone back to 3.0.0 yet) with any of gtk3.22-, qt-, or gtk3-client.

So the client still shows the resource graphics in the FoW (fog-of-war) for you, and yet the tile info popup does not match?

2022-03-25 05:35 Updated by: ddeanbrown
Comment

Correct - client still shows the resource graphics in the FoW, and yet the tile info popup does not match. Different behavior than in 2.6.6

Maybe has already been fixed and 3.0.1 will be OK.

2022-03-25 05:54 Updated by: cazfi
Comment

Reply To ddeanbrown

Maybe has already been fixed and 3.0.1 will be OK.

I can't reproduce with 3.0.0 either, so I don't see a difference between 3.0.0 and HEAD. It's hard to imagine any of the changes gone in to have fixed this (as a side-effect)

Which ruleset are you using?

2022-03-25 06:11 Updated by: ddeanbrown
Comment

Didn't expect ruleset would make a difference, but it does! Works OK with default ruleset and not with my custom one, which has additional resource types (but the bug is not just with the added ones). Will have to investigate some more, could possibly be a problem with my custom ruleset.

2022-03-25 14:26 Updated by: cazfi
Comment

I don't understand how there could be difference between seen and FoW tiles, but it's the extra "category" field that controls how the popup lists the extra

; category = How UI should categorize this extra. One of
; "Infra", "Natural", "Nuisance", "Resource",
; or "Bonus"

2022-03-26 13:23 Updated by: ddeanbrown
Comment

Ruleset was a wild goose chase, I was seeing the bug when loading a saved game, and don't see it when starting a new game with my same custom ruleset. The problem is with saved files, load any saved game file with any ruleset and then the bug happens.

That's a lot more plausible, the code doing the save could handle fogged tiles differently.

2022-03-26 16:54 Updated by: cazfi
  • Owner Update from (None) to cazfi
  • Resolution Update from None to Accepted
  • Milestone Update from (None) to 3.0.1 (closed)
Comment

Thanks, it was easy to reproduce by loading a saved game.

2022-03-28 07:39 Updated by: ddeanbrown
Comment

Verified that it's OK in 2.6.6

2022-04-07 12:00 Updated by: cazfi
  • Status Update from Open to Closed
  • Resolution Update from Accepted to Fixed

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login