Rename type checking funs to is?
Now type checking funs are named for each such as "STR.str?" or "DATE_TIME.date_time?". It is troublesome and does not go with "new".
So let's rename them "is?".
Working on the branch issue_39921-type-checking-fun-is_p
Several funs cannot suit this design:
Closed by the commit 3e68015778fdca7870d9a0abcf9ddd88d83c6733