Forums: 【御礼は忘れずに】linuxBean質問スレッド【ハンドルネーム必須】 (Thread #37039)

コーデックセットがインストールできない (2015-08-05 15:19 by powsus4 #76697)

設定ウィザードで、コーデックセットを選択してインストールしようとしたのですが、
エラーになってインストールされません。
(再度設定ウィザードを開くと、チェックボックスも入ってません。)

そこで、一部のコーデックのみインストールを試みましたがエラーになりました。
依存関係をたどってみましたが、以下の操作で行き詰まってしまいました。
解決方法があれば教えていただきたいです。


> sudo apt-get install gstreamer1.0-plugins-bad
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
インストールすることができないパッケージがありました。おそらく、あり得
ない状況を要求したか、(不安定版ディストリビューションを使用しているの
であれば) 必要なパッケージがまだ作成されていなかったり Incoming から移
動されていないことが考えられます。
以下の情報がこの問題を解決するために役立つかもしれません:

以下のパッケージには満たせない依存関係があります:
gstreamer1.0-plugins-bad : 依存: libgles2-mesa (>= 7.8.1) または
libgles2
E: 問題を解決することができません。壊れた変更禁止パッケージがあります。

>sudo apt-get install libgles2-mesa
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
インストールすることができないパッケージがありました。おそらく、あり得
ない状況を要求したか、(不安定版ディストリビューションを使用しているの
であれば) 必要なパッケージがまだ作成されていなかったり Incoming から移
動されていないことが考えられます。
以下の情報がこの問題を解決するために役立つかもしれません:

以下のパッケージには満たせない依存関係があります:
libgles2-mesa : 依存: libglapi-mesa (= 10.1.3-0ubuntu0.4)
E: 問題を解決することができません。壊れた変更禁止パッケージがあります。

>sudo apt-get install libglapi-mesa
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
libglapi-mesa は既に最新バージョンです。

Reply to #76697×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

Re: コーデックセットがインストールできない (2015-08-08 11:06 by やかん人 #76708)

[メッセージ #76697 への返信]

まず依存関係を修復する
//$sudo apt-get -f install
"ubuntu 依存関係修復”
などで検索してみる。
設定ウィザードはエラーが出るとチェックが外れます。


> 設定ウィザードで、コーデックセットを選択してインストールしようとしたのですが、
> エラーになってインストールされません。
> (再度設定ウィザードを開くと、チェックボックスも入ってません。)
>
> そこで、一部のコーデックのみインストールを試みましたがエラーになりました。
> 依存関係をたどってみましたが、以下の操作で行き詰まってしまいました。
> 解決方法があれば教えていただきたいです。
>
>
> > sudo apt-get install gstreamer1.0-plugins-bad
> パッケージリストを読み込んでいます... 完了
> 依存関係ツリーを作成しています
> 状態情報を読み取っています... 完了
> インストールすることができないパッケージがありました。おそらく、あり得
> ない状況を要求したか、(不安定版ディストリビューションを使用しているの
> であれば) 必要なパッケージがまだ作成されていなかったり Incoming から移
> 動されていないことが考えられます。
> 以下の情報がこの問題を解決するために役立つかもしれません:
>
> 以下のパッケージには満たせない依存関係があります:
> gstreamer1.0-plugins-bad : 依存: libgles2-mesa (>= 7.8.1) または
> libgles2
> E: 問題を解決することができません。壊れた変更禁止パッケージがあります。
>
> >sudo apt-get install libgles2-mesa
> パッケージリストを読み込んでいます... 完了
> 依存関係ツリーを作成しています
> 状態情報を読み取っています... 完了
> インストールすることができないパッケージがありました。おそらく、あり得
> ない状況を要求したか、(不安定版ディストリビューションを使用しているの
> であれば) 必要なパッケージがまだ作成されていなかったり Incoming から移
> 動されていないことが考えられます。
> 以下の情報がこの問題を解決するために役立つかもしれません:
>
> 以下のパッケージには満たせない依存関係があります:
> libgles2-mesa : 依存: libglapi-mesa (= 10.1.3-0ubuntu0.4)
> E: 問題を解決することができません。壊れた変更禁止パッケージがあります。
>
> >sudo apt-get install libglapi-mesa
> パッケージリストを読み込んでいます... 完了
> 依存関係ツリーを作成しています
> 状態情報を読み取っています... 完了
> libglapi-mesa は既に最新バージョンです。

Reply to #76697

Reply to #76708×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login