• R/O
  • HTTP
  • SSH
  • HTTPS

luatexja: Commit

ソースコードの管理場所


Commit MetaInfo

Revisiona621db9b2c6f139985feab5bc364d76f4639b21d (tree)
Time2018-08-25 06:22:46
AuthorHironori Kitagawa <h_kitagawa2001@yaho...>
CommiterHironori Kitagawa

Log Message

ltj-latex.sty: \RequirePackage in \AtEndOfPackage causes an error

Change Summary

Incremental Difference

--- a/src/ltj-latex.sty
+++ b/src/ltj-latex.sty
@@ -33,7 +33,13 @@
3333 \@ifnextchar[{\ltj@pkgpatch@im@{#1}}{\ltj@pkgpatch@im@{#1}[lltjp-#1]}}%]
3434 \def\ltj@pkgpatch@im@#1[#2]{%
3535 \AtEndOfPackageFile*{#1}{%
36- \@ifpackageloaded{#2}{}{\RequirePackage{#2}}%
36+ \@ifpackageloaded{#2}{}{%
37+ \@namedef{ver@#2.\@pkgextension}{0000/00/00}%dummy
38+ \if\catcode`@=11\let\ltj@temp\relax\else
39+ \edef\ltj@temp{\noexpand\catcode`@=\the\catcode`@\relax}\makeatletter
40+ \fi
41+ \@@input{#2.\@pkgextension}\ltj@temp
42+ }%
3743 }%
3844 }
3945
Show on old repository browser