Ticket #8281

mecab-perl compile error
Open Date: 2006-04-10 18:41 Last Update: 2009-11-10 23:57

Reporter:
Owner:
(None)
Status:
Closed
Component:
(None)
MileStone:
(None)
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
None
File:
None

Details

mecab-perl 0.90をコンパイルしようとするとエラーになります。
Mac OS X 10.3.9
gcc 3.3
perl 5.8.8 (built for darwin-thread-multi-2level)
ExtUtils::MakeMaker 6.30

>perl Makefile.PL
Checking if your kit is complete...
Looks good
Writing Makefile for MeCab

>make
cp MeCab.pm blib/lib/MeCab.pm
g++ -c -I/usr/local/include -fno-common -DPERL_DARWIN
-no-cpp-precomp -fno-strict-aliasing -pipe
-I/usr/local/BerkeleyDB.4.4/include
-I/usr/local/openssl/include -I/usr/local/include -Os
-DVERSION=\"0.90\" -DXS_VERSION=\"0.90\"
"-I/usr/local/lib/perl5/5.8.8/darwin-thread-multi-2level/CORE"
MeCab_wrap.cxx
In file included from MeCab_wrap.cxx:708:
/usr/local/lib/perl5/5.8.8/darwin-thread-multi-2level/CORE/perl.h:2700:
error: parse
error before `__attribute__'
/usr/local/lib/perl5/5.8.8/darwin-thread-multi-2level/CORE/perl.h:2710:
error: parse
error before `__attribute__'
/usr/local/lib/perl5/5.8.8/darwin-thread-multi-2level/CORE/perl.h:2710:
error: syntax
error before `)' token
In file included from
/usr/local/lib/perl5/5.8.8/darwin-thread-multi-2level/CORE/iperlsys.h:51,
from
/usr/local/lib/perl5/5.8.8/darwin-thread-multi-2level/CORE/perl.h:2733,
from MeCab_wrap.cxx:708:
/usr/local/lib/perl5/5.8.8/darwin-thread-multi-2level/CORE/perlio.h:117:
error: parse
error before `__attribute__'
...
以下これが連続して止まってしまいます。

Ticket History (1/1 Histories)

2009-11-10 23:57 Updated by: honehone
  • Status Update from Open to Closed
  • Ticket Close date is changed to 2009-11-10 23:57

Attachment File List

No attachments

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login