Forums: ・フォーラム (Thread #8951)

JStyle 3.1.1.0 +J2SDK 1.4.2_09でエラー (2005-10-05 13:05 by discypus #16996)

JStyle 3.1.1.0を入れたEclipse3.1.1をJ2SDK 1.4.2_09を使って起動すると、次のエラーが出ます。
「Problems Opening Page org/eclipse/swt/custom/StyledText? (Unsupported major.minor version 49.0) 」

StyledText?がJDK5.0の-target 1.5でコンパイルされているようです

classファイルをダンプしたところ、
org.eclipse.swt.win32.win32.x86_3.1.1.0.jar/org/eclipse/swt/custom/StyledText.classは
先頭から4バイト目以後が 00 00 00 31 = 49.0 (=JDK5.0?)

jp.sourceforge.mergedoc.jstyle_3.1.1.0.jar/org/eclipse/swt/custom/StyledText.classは
00 00 00 2E = 46.0 (=J2SDK 1.4.?) でした。

Reply to #16996×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

RE: JStyle 3.1.1.0 +J2SDK 1.4.2_09でエラー (2005-10-06 00:38 by cypher256 #17007)

詳細な情報ありがとうございます。助かります。
ご指摘のとおり、JDK5.0 レベルでビルドしていました。
1.4 で再ビルドし、3.1.1.1 としてリリースしましたので、
お試しください。
Reply to #16996

Reply to #17007×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

RE: JStyle 3.1.1.0 +J2SDK 1.4.2_09でエラー (2005-10-06 10:49 by discypus #17010)

JStyle 3.1.1.1 に入れ替えて、
j2sdk1.4.2_09のjavawでEclipse 3.1.1をで起動できました。

迅速な対応をありがとうございました。
Reply to #16996

Reply to #17010×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login