Ticket #26494

プラグインを有効にするチェックボックスが使えない / The plugin enable checkbox doesn't work

Open Date: 2011-10-10 14:04 Last Update: 2012-01-17 11:08

Reporter:
(Anonymous)
Owner:
Type:
Status:
Closed
Component:
MileStone:
(None)
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
None
File:
None

Details

Blenderを使い始めたばかりの初心者で、2.59/64bitをexeインストーラーからインストールして使っています。 Pythonは付属のものを使っているはずです。 プラグインのインストールはできたのですが、プラグインを有効にしようとしても、チェックボックスが効きませんでした。

コンソールの出力を見てみると、Blenderが"import bl25 as 25"という処理をしようとした時、bl25というモジュールを見つけられていないようでした。 そこで、"from . import"という感じで全てのimport文を書き換えたところ、チェックボックスが動作するようになり、プラグインが使えるようになりました。

更新履歴にこれに関連しているような記述があったので、私の環境ではこの変更がうまく動作しないのかもしれません。

I just started to use blender and currently using 2.59/64bit installed from exe installer. I should be using Python comes with the installer. I could install MeshIO Plugin but when I tried to enable the plugin, the checkbox didn't work.

When I checked console output, it says that Blender couldn't find module bl25 when it tries to do "import bl25 as bl". So I just added "from ." to all import parts and then the checkbox became available.

After that, I noticed that there is a update history which seems to have something to do with this issue. I guess the latest change doesn't work in my environment.

Ticket History (3/4 Histories)

2011-10-10 14:04 Updated by: None
  • New Ticket "プラグインを有効にするチェックボックスが使えない / The plugin enable checkbox doesn't work" created
2011-12-04 23:16 Updated by: yo-zi
Comment
(This comment has been deleted)
2011-12-04 23:27 Updated by: yo-zi
Comment

リリースファイル一覧にあるpymeshio-1.9.0.zip に関しては, これの修正が入る前のもののようです。2.3.xでは解消されています。

2012-01-17 11:08 Updated by: ousttrue
  • Status Update from Open to Closed
  • Ticket Close date is changed to 2012-01-17 11:08
Comment

python3で削除された"暗黙の相対import"に関する問題で、当初この辺りの仕様をちゃんと理解していませんでした。 ご報告ありがとうございます。

Attachment File List

No attachments

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login