Ticket #40378

g++ emits multiple publicly visible instances of vsnprintf()

Open Date: 2020-05-03 05:28 Last Update: 2020-05-03 19:44

Reporter:
Owner:
(None)
Type:
Status:
Closed
Component:
MileStone:
(None)
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Out of Date
File:
None
Vote
Score: -1
0.0% (0/1)
100.0% (1/1)

Details

Per Keith (see https://osdn.net/projects/mingw/lists/archive/users/2019-August/000334.html), the changes to <stdio.h>, to resolve https://osdn.net/projects/mingw/ticket/39224, cause g++ to emit multiple publicly visible instances of vsnprintf()

As a result, I get this link error: c:/mingw/bin/../lib/gcc/mingw32/8.2.0/../../../../mingw32/bin/ld.exe: c:/mingw/bin/../lib/gcc/mingw32/8.2.0/../../..\libmingwex.a(vsnprintf.o):(.text+0x0): multiple definition of vsnprintf; Sudoku16.o:c:/mingw/include/stdio.h:491: first defined here

Note that, contrary to statements in messages following the one I referred above, I continue to get the link error after downgrading to mingwrt-5.2.1 and also mingwrt-5.1.1

So, per Keith's request in the above message, I'm opening a formal request to hopefully get this resolved.

Ticket History (3/4 Histories)

2020-05-03 05:28 Updated by: jrromanow
  • New Ticket "g++ emits multiple publicly visible instances of vsnprintf()" created
2020-05-03 07:23 Updated by: keith
  • Component Update from (None) to WSL
  • Resolution Update from None to Out of Date
Comment

Today, you should be using MinGW's GCC-9.2.0 release, and mingwrt-5.3.1/w32api-5.3.1.

This appears to be a duplicate of ticket #39757, which I raised myself, following up on the e-mails to which you refer, and subsequently closed as "fixed", for mingwrt-5.2.3. Unless you can provide a formal test case, to demonstrate that the #39757 resolution was not effective, when compiling with current tools, I will close this as an "out of date" duplicate.

2020-05-03 10:16 Updated by: jrromanow
Comment

Apologies, Keith. I did search for a ticket with vsnprintf or mingwrt in it but apparently, being new at this site, I didn't do it right.

Thank you for the fix information. All is well now.

2020-05-03 19:44 Updated by: keith
  • Status Update from Open to Closed
Comment

Reply To jrromanow

Apologies, Keith. I did search for a ticket with vsnprintf or mingwrt in it but apparently, being new at this site, I didn't do it right.

No problem; FTR, when viewing the ticket list, closed tickets are not shown in the default view. To see them, you need to check the "closed" option box, then click the "search" button to refresh the view.

Thank you for the fix information. All is well now.

Thanks for this confirmation. Closing.

Attachment File List

No attachments

Edit

Please login to add comment to this ticket » Login