Ticket #40489

MinGW-get-setup.exe creates files blocked by Bitdefender

Open Date: 2020-06-17 22:27 Last Update: 2020-06-18 22:21

Reporter:
Owner:
(None)
Type:
Status:
Closed
Component:
MileStone:
(None)
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Invalid
File:
None
Vote
Score: 0
No votes
0.0% (0/0)
0.0% (0/0)

Details

Hi. I recently downloaded mingw-get-setup.exe. The problem is that the files that I create with a .cpp extension are blocked by the antivirus installed on my computer, Bitdefender.

Information:

Windows 10

gcc version 9.2.0 (MinGW.org GCC Build-20200227-1)

GNU ld (GNU Binutils) 2.32

Microsoft shell - cmd.exe

MinGW version 0.6.3-pre-20170905-1

I receive this message:

C:\Users\Maria\Desktop>g++ hello.cpp c:/mingw/bin/../lib/gcc/mingw32/9.2.0/../../../../mingw32/bin/ld.exe: cannot open output file a.exe: Permission denied collect2.exe: error: ld returned 1 exit status

I am trying to compile and execute some files locally and this is not the first time I run into this problem. In the past, I decided to use an online compiler after observing that it doesn’t work locally, but it turns out I need to use MinGW in the end.

The antivirus warns about this after trying to turn a file into an executable:

The file C:\Users\Maria\Desktop\a.exe is infected with Gen:Variant.Ursu.852514 and was moved to quarantine. It is recommended that you run a System Scan to make sure your system is clean.

I don't know if it is safe to add this warning to exceptions, so that the antivirus ignores it. I thought that maybe it can be a false alarm from the antivirus.

If there is some information about this topic, is it possible that I receive a link on with how to deal with this problem?

Thanks for your time!

Ticket History (2/2 Histories)

2020-06-17 22:27 Updated by: sofia190
  • New Ticket "MinGW-get-setup.exe creates files blocked by Bitdefender" created
2020-06-18 22:21 Updated by: keith
  • Resolution Update from None to Invalid
  • Status Update from Open to Closed
Comment

Firstly, mingw-get-setup.exe does not create files — it installs mingw-get, and nothing more. It most certainly is not responsible for creating a.exe.

If, what you really mean is that you ran mingw-get-setup.exe, to install mingw-get, subsequently used mingw-get to install a compiler suite, which you then used to compile your own a.exe and BitDefender doesn't like that ... well that's hardly a problem with mingw-get, much less with mingw-get-setup.exe. My own view is that this is a BitDefender issue — most likely a false positive detection. In any case, it isn't a MinGW issue; you need to make your own decision about how much faith you put in BitDefender ... we cannot help you with that.

Attachment File List

No attachments

Edit

Please login to add comment to this ticket » Login