Ticket #30238

メニュー項目を「未定義」「空行」としか読み上げない

Open Date: 2012-12-01 18:25 Last Update: 2013-10-27 16:32

Reporter:
Owner:
(None)
Type:
Status:
Closed
Component:
(None)
MileStone:
(None)
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Works For Me
File:
None

Details

署名された 2012.3.1jp リリース候補版で見つけた現象ですが、どうやら NVDA 2012.3 本家版でも起きているので、のちほど本家にフィードバックします。

電子署名された NVDA をインストールすると、Windows 7 のデバイスマネージャーのツリービューの項目を読みあげるのですが、2012.3 では読みあげが行なわれません。ツリービュー項目を開いてダイアログを出すと、ダイアログは読み上げています。

ログをデバッグモードで取ると、下記のようなメッセージを見つけました。

DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (18:19:27):
oleacc.AccessibleObjectFromEvent with window 5899982, objectID -4 and childID 16: [Error -2147312566] タイプ ライブラリ/DLL の読み込みエラーです。
DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (18:19:27):
oleacc.AccessibleObjectFromEvent with window 5899982, objectID -4 and childID 0: [Error -2147312566] タイプ ライブラリ/DLL の読み込みエラーです。
IO - inputCore.InputManager.executeGesture (18:19:29):
Input: kb(laptop):downArrow
DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (18:19:29):
oleacc.AccessibleObjectFromEvent with window 5899982, objectID -4 and childID 28: [Error -2147312566] タイプ ライブラリ/DLL の読み込みエラーです。
DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (18:19:29):
oleacc.AccessibleObjectFromEvent with window 5899982, objectID -4 and childID 28: [Error -2147312566] タイプ ライブラリ/DLL の読み込みエラーです。
IO - inputCore.InputManager.executeGesture (18:19:29):
Input: kb(laptop):rightArrow
DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (18:19:29):
oleacc.AccessibleObjectFromEvent with window 5899982, objectID -4 and childID 28: [Error -2147312566] タイプ ライブラリ/DLL の読み込みエラーです。
IO - inputCore.InputManager.executeGesture (18:19:30):
Input: kb(laptop):downArrow
DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (18:19:30):
oleacc.AccessibleObjectFromEvent with window 5899982, objectID -4 and childID 32: [Error -2147312566] タイプ ライブラリ/DLL の読み込みエラーです。
DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (18:19:30):
oleacc.AccessibleObjectFromEvent with window 5899982, objectID -4 and childID 32: [Error -2147312566] タイプ ライブラリ/DLL の読み込みエラーです。

Ticket History (3/8 Histories)

2012-12-01 18:25 Updated by: nishimoto
  • New Ticket "電子署名されていても Windows 7 x64 のデバイスマネージャを読まない" created
2012-12-01 18:41 Updated by: nishimoto
Comment

NVDA-support に NVDA And The Microsoft Windows 7 64 Device Manager というスレッドがあったので、下記のように報告しました。

バグなのか、バグではないのか、本家が 2012.3.1 で直すのか 2013.1 で直すのか、様子をみたいと思います。

Hello,

I can reproduce the issue that "DeviceManager" tree view is not announced.

Procedures:

- Windows 7 sp1 x64 Ultimate (English interface. also reproduced with
Japanese interface)
- Installed copy of NVDA 2012.3
- Open control panel / system and sequrity / hardware and sound / Device Manager
- Move focus to the tree view.

The log file (debug level) is as follows.
https://dl.dropbox.com/u/62564469/nvda-121201.log

This includes messages such as:

DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (18:28:17):
oleacc.AccessibleObjectFromEvent with window 132596, objectID -4 and childID 1:
DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (18:28:17):
oleacc.AccessibleObjectFromEvent with window 67122, objectID -4 and
childID 1: [Error -2147312566] Error loading type library/DLL
DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (18:28:17):
oleacc.AccessibleObjectFromEvent with window 67122, objectID -4 and
childID 0: [Error -2147312566] Error loading type library/DLL

I am not sure the warning is related to the issue.
2012-12-01 21:53 Updated by: nishimoto
Comment

Windows 8 Pro x86 English と NVDA 2012.3 ではデバイスマネージャーの項目は読みあげできている、ということを報告しました。

With Windows 8 Pro x86 English and NVDA 2012.3, Device Manager items
are announced.
Debug log is as follows:
https://dl.dropbox.com/u/62564469/nvda-121201-win8-x86.log
The log contains "Unspecified error", however, it is working.
2012-12-03 00:03 Updated by: nishimoto
Comment

デバイスマネージャーの項目を読みあげない現象が起きた Windows 7 sp1 x64 環境を、以下のバージョンの NVDA で試して、いずれも同じ状況である(項目を読みあげない)ことを確認しました。

  • NVDA 2012.2.1
  • NVDA 日本語版 2012.2.1jp
  • NVDA 2012.3
  • NVDA 日本語版 2012.3.1jp リリース候補版

一方で NVDA-support のメーリングリストでは、ちゃんと読みあげしているというコメントもありました。

このテスト環境に固有の現象かも知れません。

いずれにせよ、過去のバージョンと現在のバージョンで状況が同じなのであれば、リリースの妨げにはならないと判断できそうです。

2013-03-22 10:42 Updated by: nishimoto
  • Ticket Close date is changed to 2013-03-22 10:42
  • Status Update from Open to Closed
  • Resolution Update from None to Works For Me
Comment

他に報告がないので、解決法「動いてるけど?」(本家チケットの works for me みたいな意味合いでしょうか)として、マイルストーン無指定のまま、完了にします。

2013-05-09 14:14 Updated by: nishimoto
Comment

作業中のスナップショットで、下記のような現象がありましたが、新しい環境で Windows 7 64ビットをインストールしなおしたところ解決しました。

どうやら Windows 環境に依存するようなので、記録のためにここに書いておきます。

現象:メモ帳のメニュー項目などが読み上げできず「未定義」「空行」などになっている。

下記のようなログを出している:

IO - inputCore.InputManager.executeGesture (11:52:16):
Input: kb(desktop):downArrow
DEBUGWARNING - IAccessibleHandler.accessibleObjectFromEvent (11:52:16):
oleacc.AccessibleObjectFromEvent with window 328942, objectID -4 and childID 4: [Error -2147312566] タイプ ライブラリ/DLL の読み込みエラーです。
DEBUG - synthDrivers.nvdajp_jtalk.SynthDriver._get_voice (11:52:16):
_get_voice called
IO - speech.speak (11:52:16):
Speaking [LangChangeCommand ('ja'), u'空行']
DEBUG - synthDrivers.jtalk.mecab.Mecab_analysis (11:52:16):
空行,名詞,一般,*,*,*,*,空行,クーギョー,クーギョー,0/4,C0
2013-09-28 15:16 Updated by: nishimoto
  • Summary Updated
Comment

最近 Windows 7 64ビットの環境で、またこの現象が起きました。

現象:メモ帳のメニュー項目などが読み上げできず「未定義」「空行」などになっている。

ログ記録レベルをデバッグにすると「タイプ ライブラリ/DLL の読み込みエラー」が発生している。

しかし、いくつかのアプリケーションをアンインストールしてみたら、問題が解決しました。

ひとつずつ試さなかったので、どのアプリがこの問題を起こすのか突き止められませんでしたが、Adobe Reader や Microsoft WPF Toolkit などが含まれていたと記憶しています。

チケットのタイトルを「電子署名されていても Windows 7 x64 のデバイスマネージャを読まない」から変更しました。

2013-10-27 16:32 Updated by: nishimoto
Comment

下記のようにすると、メモ帳の読みあげについては問題が解決したので、記録しておきます。

  • コマンドプロンプトを管理者権限で開く
  • c:\windows\system32 にて regsvr32 oleacc.dll を実行する

Attachment File List

No attachments

Edit

Please login to add comment to this ticket » Login