[PukiWiki-users 268] PukiWikiのPHP5.4対応パッケージ を作りました (BugTrack2/353 提案ベース)

Back to archive index

Hirokazu Moriguchi umori****@gmail*****
2014年 7月 5日 (土) 13:46:25 JST


こんにちは。 umorigu です。

PukiWiki-dev サイト に 「PHP 5.4 対応版リリースの提案」を投稿していますが
この提案をベースに、パッケージ(配布できるzipファイル、及びpatch)を作成しました。

BugTrack2/353/ PHP5.4対応版 - PukiWiki-dev
http://pukiwiki.sourceforge.jp/dev/?BugTrack2%2F353%2FPHP5.4%C2%D0%B1%FE%C8%C7

このページに1.4.7既存サイトのPHP5.4対応方法も書いています。
UTF-8 と EUC_JP の両方に対応しています。

バージョンは提案の通り1.5.0としています。

実際のファイルはこちらにおいています
http://sourceforge.jp/users/umorigu/pf/pukiwiki15/files/


r1.4.7_notbとCVS版での変更を元にしているので、
今後公式にリリースがあったとしても内容は近いものになると期待しています。

自分の周りでも何件かPHP5.4移行の話が出ているので、必要に迫られて書きました。



パッケージの内容や対応手順に対して、何か気づかれた点、ご意見などあれば
メールやWiki内コメントにてお伝えくださると幸いです。


よろしくお願いいたします。

-- 
umorigu <umori****@gmail*****>



PukiWiki-users メーリングリストの案内
Back to archive index