Forums: ヘルプ (Thread #37877)

Soccerwindow5.1.0 on ubuntu 16.04 (2016-07-12 13:45 by moon #78328)

when i want to make soccerwindow 5.1.0 on ubuntu 16.04 i faced with this error :
g++: error: unrecognized command line option ‘-pthread-lQtGui’
Makefile:415: recipe for target 'soccerwindow2-qt4' failed
make[3]: *** [soccerwindow2-qt4] Error 1

Qt version 4.8.7
rcssserver and monitor are already installed
libscrc version 4.1.0
thanks

Reply to #78328×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

Re: Soccerwindow5.1.0 on ubuntu 16.04 (2016-10-18 10:20 by Fellipe Adorno #78895)

[Responder a Mensagem #78328]
> when i want to make soccerwindow 5.1.0 on ubuntu 16.04 i faced with this error :
> g++: error: unrecognized command line option ‘-pthread-lQtGui’
> Makefile:415: recipe for target 'soccerwindow2-qt4' failed
> make[3]: *** [soccerwindow2-qt4] Error 1
>
> Qt version 4.8.7
> rcssserver and monitor are already installed
> libscrc version 4.1.0
> thanks
Hello!
It is an error in qt.m4 file. You can solve it just searching for line 143 and putting a space after first ")". It will seem like:
QT4_LDADD="$($PKG_CONFIG --static --libs-only-other $QT4_REQUIRED_MODULES) $($PKG_CONFIG --static --libs-only-l $QT4_REQUIRED_MODULES)"
That error appear to me several times before in others autotool's programs.
Reply to #78328

Reply to #78895×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

Re: Soccerwindow5.1.0 on ubuntu 16.04 (2016-10-18 10:23 by Fellipe Adorno #78896)

[Responder a Mensagem #78895]
> [Responder a Mensagem #78328]
> > when i want to make soccerwindow 5.1.0 on ubuntu 16.04 i faced with this error :
> > g++: error: unrecognized command line option ‘-pthread-lQtGui’
> > Makefile:415: recipe for target 'soccerwindow2-qt4' failed
> > make[3]: *** [soccerwindow2-qt4] Error 1
> >
> > Qt version 4.8.7
> > rcssserver and monitor are already installed
> > libscrc version 4.1.0
> > thanks
> Hello!
> It is an error in qt.m4 file. You can solve it just searching for line 143 and putting a space after first ")". It will seem like:
> QT4_LDADD="$($PKG_CONFIG --static --libs-only-other $QT4_REQUIRED_MODULES) $($PKG_CONFIG --static --libs-only-l $QT4_REQUIRED_MODULES)"
> That error appear to me several times before in others autotool's programs.

I forgot to say that you'll need to do automake/autoconf commands again, but you can using ./boostrap to simply your life instead, and restart ./configure before do a make command as was installing for the first time.
Reply to #78895

Reply to #78896×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login