File Info

Rev. efeab20e689880041b1ce76d479bb22c776d3f74
Size 3,778 bytes
Time 2020-07-04 19:41:12
Author simphone
Log Message

simphone 0.8.1

Content

diff -urb build/makedepend-1.0.5/configure build/makedepend/configure
--- build/makedepend-1.0.5/configure
+++ build/makedepend/configure
@@ -10916,91 +10916,7 @@
 
 
 
-pkg_failed=no
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for X" >&5
-$as_echo_n "checking for X... " >&6; }
-
-if test -n "$X_CFLAGS"; then
-    pkg_cv_X_CFLAGS="$X_CFLAGS"
- elif test -n "$PKG_CONFIG"; then
-    if test -n "$PKG_CONFIG" && \
-    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"xproto >= 7.0.17\""; } >&5
-  ($PKG_CONFIG --exists --print-errors "xproto >= 7.0.17") 2>&5
-  ac_status=$?
-  $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-  test $ac_status = 0; }; then
-  pkg_cv_X_CFLAGS=`$PKG_CONFIG --cflags "xproto >= 7.0.17" 2>/dev/null`
-else
-  pkg_failed=yes
-fi
- else
-    pkg_failed=untried
-fi
-if test -n "$X_LIBS"; then
-    pkg_cv_X_LIBS="$X_LIBS"
- elif test -n "$PKG_CONFIG"; then
-    if test -n "$PKG_CONFIG" && \
-    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"xproto >= 7.0.17\""; } >&5
-  ($PKG_CONFIG --exists --print-errors "xproto >= 7.0.17") 2>&5
-  ac_status=$?
-  $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-  test $ac_status = 0; }; then
-  pkg_cv_X_LIBS=`$PKG_CONFIG --libs "xproto >= 7.0.17" 2>/dev/null`
-else
-  pkg_failed=yes
-fi
- else
-    pkg_failed=untried
-fi
-
-
-
-if test $pkg_failed = yes; then
-
-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
-        _pkg_short_errors_supported=yes
-else
-        _pkg_short_errors_supported=no
-fi
-        if test $_pkg_short_errors_supported = yes; then
-	        X_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "xproto >= 7.0.17" 2>&1`
-        else
-	        X_PKG_ERRORS=`$PKG_CONFIG --print-errors "xproto >= 7.0.17" 2>&1`
-        fi
-	# Put the nasty error message in config.log where it belongs
-	echo "$X_PKG_ERRORS" >&5
-
-	as_fn_error $? "Package requirements (xproto >= 7.0.17) were not met:
-
-$X_PKG_ERRORS
-
-Consider adjusting the PKG_CONFIG_PATH environment variable if you
-installed software in a non-standard prefix.
-
-Alternatively, you may set the environment variables X_CFLAGS
-and X_LIBS to avoid the need to call pkg-config.
-See the pkg-config man page for more details.
-" "$LINENO" 5
-elif test $pkg_failed = untried; then
-	{ { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
-as_fn_error $? "The pkg-config script could not be found or is too old.  Make sure it
-is in your PATH or set the PKG_CONFIG environment variable to the full
-path to pkg-config.
-
-Alternatively, you may set the environment variables X_CFLAGS
-and X_LIBS to avoid the need to call pkg-config.
-See the pkg-config man page for more details.
-
-To get pkg-config, see <http://pkg-config.freedesktop.org/>.
-See \`config.log' for more details" "$LINENO" 5; }
-else
-	X_CFLAGS=$pkg_cv_X_CFLAGS
-	X_LIBS=$pkg_cv_X_LIBS
-        { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-$as_echo "yes" >&6; }
-	:
-fi
+#PKG_CHECK_MODULES(X, [xproto >= 7.0.17])
 
 ac_config_files="$ac_config_files Makefile"
 
diff -urb build/makedepend-1.0.5/configure.ac build/makedepend/configure.ac
--- build/makedepend-1.0.5/configure.ac
+++ build/makedepend/configure.ac
@@ -2,7 +2,7 @@
 dnl Process this file with autoconf to create configure.
 
 # Initialize Autoconf
-AC_PREREQ([2.60])
+AC_PREREQ([2.59])
 AC_INIT([makedepend], [1.0.5],
         [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg])
 AC_CONFIG_SRCDIR([Makefile.am])
@@ -27,6 +27,6 @@
 AC_SYS_LARGEFILE
 
 dnl Check for pkg-config packages
-PKG_CHECK_MODULES(X, [xproto >= 7.0.17])
+#PKG_CHECK_MODULES(X, [xproto >= 7.0.17])
 
 AC_OUTPUT([Makefile])
Show on old repository browser