Forums: Help (Thread #31979)

同梱のApacheをアップデートするには? (2012-04-19 23:04 by gene #63351)

こんにちは。
現在、TracLightning 2.0.9 を使用していますが、
Apacheの脆弱性対策のため、Apache HTTP Server を2.2.15以降のバージョンに
アップデートしたいと思っています。
TracLightningのバージョンアップで対応しようと思ったのですが、
TracLightning 2.5.2 も 3.1.3 も同梱のApacheは、2.2.14のようなので、
TracLightning のアップデートでは要件を満たすことができなくて困っています。
Apacheだけアップデートする方法はあるのでしょうか。

RE: 同梱のApacheをアップデートするには? (2012-04-20 16:59 by kanu #63361)

こんにちは、かぬです。

3.2.0dev-92c1c81256a6であればApache(httpd)が2.2.21になっています。
(https://bitbucket.org/okamototk/traclightning/downloads)

dev版ではありますが3.1.3からはhttpdとsvnのバージョンアップ以外は大きな変更が入っていないので、
TracLightningのバージョンアップを検討しているのであれば利用してみては如何でしょうか。

ちなみに2系から3系へのバージョンアップになりますので、「TracLightning2.xからTracLightning3.0.xへ
のアップグレードの注意」(http://sourceforge.jp/projects/traclight/wiki/TracUpgrade3_0_0)
良く読んでから行ってください。
Reply to #63351

RE: 同梱のApacheをアップデートするには? (2012-04-22 20:33 by gene #63377)

どうも、ありがとうございます。
3.2.0devで対応しようと思います。
が、ご紹介のリンクは404になりますです。
Reply to #63361

RE: 同梱のApacheをアップデートするには? (2012-04-23 21:15 by jun66j5 #63385)

> どうも、ありがとうございます。
> 3.2.0devで対応しようと思います。
> が、ご紹介のリンクは404になりますです。
このフォーラムは閉じ括弧を URL の一部だと認識するようで閉じ括弧が URL に含まれてしまっています。括弧を取り除いた ↓ の URL でアクセスしてください。

https://bitbucket.org/okamototk/traclightning/downloads
http://sourceforge.jp/projects/traclight/wiki/TracUpgrade3_0_0
Reply to #63377

RE: 同梱のApacheをアップデートするには? (2012-04-24 10:50 by gene #63391)

本当だ。閉じ括弧が含まれてますね。気がつかなかった。
ダウンロードできましたので、タイミングを見計らってアップデートしてみます。
どうもありがとうございました。
Reply to #63385