Forums: Open Discussion (Thread #26683)

I found a bug. please help me. (2010-06-28 19:21 by ldy2534 #51606)

I use xmodeom to transport a 2k file. But if I open this file in a deeper directory, may be 5 or 6 level directory, it will stop when I finished the transportation, just show a 100% complete on the screen.
And I check the data that I got , the first 128byte data I receive is ok, and I send back ACK to the sender too. but tera term repeat send the first 128byte data to me (the packet number is 1 as the first one).

1. I check the timeout of send a packet is 1 minute. I'm sure I donot exceed it.
2. The same environment I chang the PATH to a short one, it is ok.
3. I use secureCRT repeat it, the result is ok. He not repeat send the packet to me.
4. By the way , I first open some deeper directory, but select none document, and I chang the PATH to a short one where inclue my target document, I chose it and send it , the same but appear.

RE: I found a bug. please help me. (2010-06-30 13:04 by ldy2534 #51652)

I found the reasone is that every time Tera Term send me a 128bytes packet then I renturn an ACK, but Tera Term repeat the first packte to me , this happen to each packet Tera Term send, of course there is no exception for EOF ,Send EOF twice.
xmodem
baud rate: 115200
data: 8bit
parity: none
stop : 1bit
flow control: none
version :4.65
Reply to #51606

RE: I found a bug. please help me. (2010-06-30 23:46 by (del#1144) #51662)

I have some questions about this issue.

Do you send or receive a file with XMODEM?

What is a XMODEM program at remote side? lszrz or zmtx-zmrx or embedded machine?

Do you use Checksum or CRC or 1K? Binary flag is on or off?

Can you attach the log file of XMODEM?
Reply to #51652

RE: I found a bug. please help me. (2010-07-02 12:31 by ldy2534 #51695)

[Follow up Message #51662] > I have some questions about this issue.Do you send or receive a file with XMODEM?What is a XMODEM program at remote side? lszrz or zmtx-zmrx or embedded machine?Do you use Checksum or CRC or 1K? Binary flag is on or off?Can you attach the log file of XMODEM?

1.I use Tera Term as a sender with XMODEM.
2.I send a xx.bin file for upload my program. remote side is my developed board, I receive this file in my bootloader
3.I use Checksum 128bytes packet , add head and checksum is 132bytes
4.sorry about this question, I donot got is, what is Binary flag, I donot got relevent information in the protocol.

I don't know how to add the the attachment. please leave your mail address as I can send you the log .
PS: my msn ldy2534@hotmail.com . gtalk ldy2534@gtalk.com

RE: I found a bug. please help me. (2010-07-02 12:59 by (del#1144) #51696)

I opened a ticket to accept attachment file.

http://sourceforge.jp/ticket/browse.php?group_id=1412&tid=22342
Reply to #51695