Ticket #10935

discarding characters on startup?
Open Date: 2007-09-06 18:09 Last Update: 2007-12-07 08:37

Reporter:
Owner:
Status:
Closed
Component:
(None)
MileStone:
(None)
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
None
Vote
Score: 0
No votes
0.0% (0/0)
0.0% (0/0)

Details

Hi,

on startup TeraTerm behaves differently from other
terminal programs
(namely HyperTerminal 5.1, PuTTY 0.60, RealTerm 2.0.0.43).


TeraTerm starts with an empty screen whereas the others
show
"HiU!" on startup.


It seems to me that TeraTerm discards characters after
it has set DTR.

The device I'm testing with might have problems on its own
(it's a custom USB device I'm trying to program and which I
test with various terminal programs) but the
corresponding line is:


if(!tflag && uart_DTR)
{
COMPutString("HiU!\r\n");
tflag = 1; // only once
}


(Testing on Unix (Knoppix 5.0) with "cat /dev/ttyACM0"
also gives "HiU!".
Minicom 2.1 (Knoppix 5.0) starts with a blank screen
like TeraTerm though.)

I'm unsure whether discarding the characters is
intended behaviour
so I'm filing a feature request about being able to see
them:)

Greetings,
Frieder

Ticket History (3/6 Histories)

2007-10-04 14:25 Updated by: (del#24082)
  • (Group change on Tracker)
  • (Category change on Tracker)
  • Resolution Update from None to Accepted
2007-10-04 21:17 Updated by: doda
  • Owner Update from (None) to doda
2007-10-19 09:10 Updated by: doda
Comment
Logged In: YES
user_id=14322

TeraTerm clears a buffer when opening serial port.
I add a new optional setting to disable COM buffer cleaning.
Try latest snapshot and modify ClearComBuffOnOpen entry in
teraterm.ini.

http://ttssh2.sourceforge.jp/snapshot/
2007-10-19 09:11 Updated by: doda
  • Resolution Update from Accepted to Fixed
2007-12-06 13:09 Updated by: (del#1144)
  • Ticket Close date is changed to 2007-12-06 13:09
  • Status Update from Open to Closed
2007-12-07 08:37 Updated by: frief
  • Ticket Close date is changed to 2007-12-07 08:37
Comment
Logged In: YES
user_id=30671

thanks for implementing this!
(and sorry for not having responded earlier)

Attachment File List

No attachments

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login