Ticket #31555

Vote
Score: 0
No votes
0.0% (0/0)
0.0% (0/0)

TTProxy Configuration is buggy

Open Date: 2013-06-12 02:18 Last Update: 2013-06-12 02:18

Reporter: (Anonymous) Owner: (None)
Type: Bugs Status: Open
Component: TTSSH MileStone: (None)
Priority: 5 - Medium Severity: 9 - Highest
Resolution: None

Details

a couple things....

proxy configuration is HTTP + IP Address + Port

- Configure proxy from existing TeraTerm window. - Attempt SSH connection. - Pop-up alert: Connection refused. --- Issue 1 occurs at this point:




- I went back to the proxy config, to see what config options were available for SSL. Specifically, I selected SSL in the type field, saw the other fields got grayed out, so selected HTTP again and ensured the IP Address + Port were correctly configured. I closed the window with the <OK> button. - Tried SSH connection to same host. This time got prompted to accept key and enter password. --- Issue 2: Apparently, even though TeraTerm accepts & retains the proxy config, the config is not applied (correctly?) the first time.

I tried repeated the above by closing all TeraTerm windows (I hadn't saved configuration since starting the process I've described here.) and reopening, but these 2 issues didn't reproduce. Perhaps this has something to do with either the 1st attempt to configure & use a proxy after installation, or something TeraTerm keeps in memory or cache (ssh_known_hosts file?) after the 1st SSH connection goes through? I don't know.

Issue 3: - open TT window. - config proxy for HTTP as above - open SSH to hostX - close SSH to hostX - deconfig HTTP proxy - open SSH to hostX - close SSH to hostX - open SSH to hostX - close SSH to hostX - confirm TT proxy is disabled. - open PuTTY - same HTTP proxy config - open SSH to hostX in PuTTY - close SSH to hostX in PuTTY - deconfigure proxy in PuTTY - *cannot* open SSH to hostX in PuTTY !!!! connection timeout - (back to same TT window - proxy still deconfigured) - open & close SSH to hostX - open & close telnet to hostY (FWIW, hostY is local (on local subnet)) - open & close SSH to hostX - open & close telnet to hostY - close teraterm window. (proxy still showing as deconfigured here.) - close another teraterm window where I'd been trying this SSH/telnet stuff (proxy showing as deconfigured here, too.) Now.... My original teraterm window was one with a serial connection. - back on serial conn window, proxy is showing as configured. Following connections are initiated from this window. - open & close SSH to hostX - Fails: open telnet to hostY (doesn't time-out -- that I see -- but after the next step, I go back to this window and see the connection is "disconnected") - open & close SSH to hostX - on serial conn window, deconfigure proxy by just selection "without proxy;" leave other fields as is - open telnet to hostY -- CRASH.


- back on serial conn window, configure proxy:








dang it. I jumped the gun here concerning the crash. The above description has previously applied. I can't rewrite all this stuff, so I'm leaving but saying that I missed this: today the crash happens when I telnet the HostY (local) when proxy is enabled. I did this 2x, and the initial crash vectors (on the pop-ups) show all registers having the same values.

I tried doing as described above (selecting without and leaving the other fields intact,) and now I *can* telnet OK.

Hope this isn't too confusing. Running TeraTerm 4.78 and TTProxy 1.0.0.18 on WinXP right now, but I've seen the crash since the 4.60s builds. I'd previously sent emails about it, but I don't see any tickets on the subject, so I'm opening this.

Attachment File List

No attachments

Ticket History (1/1 Histories)

2013-06-12 02:18 Updated by: None
  • New Ticket "TTProxy Configuration is buggy" created

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login