Ticket #37545

Vote
Score: 0
No votes
0.0% (0/0)
0.0% (0/0)

COM Port Not Being Saved

Open Date: 2017-10-02 15:33 Last Update: 2017-10-06 13:13

Reporter: toml12953 Owner: (None)
Type: Bugs Status: Open
Component: Tera Term MileStone: (None)
Priority: 5 - Medium Severity: 5 - Medium
Resolution: None

Details

When I set the various parameters of a connection (Port, Baud rate, Data, Parity, Stop, Flow Control, Xmit and Rcv delay) I can save the setup and restore it next time I launch TT. All the other parameters are restored except Port. That setting always reverts to COM1.

Attachment File List

No attachments

Ticket History (3/4 Histories)

2017-10-02 15:33 Updated by: toml12953
  • New Ticket "COM Port Not Being Saved" created
2017-10-02 16:51 Updated by: doda
Comment

Not reproduced.

What is the value of ComPort in TERATERM.INI after saving?

2017-10-02 20:35 Updated by: None
Comment

Reply To doda

Not reproduced. What is the value of ComPort in TERATERM.INI after saving?

If I save to TERATERM.INI, the ComPort saves correctly to TERATERM.INI and TT will have the changed COM port when I restart it.

The problem is when I try to save and restore using a different file name. The INI file I save to shows the ComPort I changed to but when I restore my modified INI, the port remains at 1.

Example:

Change COM port to 2, Data to 7-bit then:

Click

Setup Save Setup... type in any file name other than TERATERM (let's use TEST.INI)

Close TeraTerm Open TeraTerm Click

Setup Restore setup... type in TEST.INI

Data is restored to 7 bit but COM port remains at 1.

2017-10-06 13:13 Updated by: doda
  • Priority Update from 7 to 5 - Medium
Comment

Restore setup does not change the current connection.

To change the default COM port, use the /F= option when launching Tera Term.

ttermpro.exe /F=TEST.INI

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login