Ticket #40986

Failed login if password has pipe character

Open Date: 2020-11-20 20:08 Last Update: 2020-11-26 13:18

Reporter:
(Anonymous)
Owner:
(None)
Type:
Status:
Open
Component:
MileStone:
(None)
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Works For Me
File:
None
Vote
Score: 0
No votes
0.0% (0/0)
0.0% (0/0)

Details

Hi. If I try to connect to a SSH device using a password having pipe character (like in "mypassw|ord") then login failed. Can you do something? I am using Teraterm 4.105.

Ticket History (3/4 Histories)

2020-11-20 20:08 Updated by: None
  • New Ticket "Failed login if password has pipe character" created
2020-11-20 20:18 Updated by: nmaya
  • Resolution Update from None to Works For Me
  • Component Update from Tera Term to TTSSH
Comment

Hi,

Is it from "SSH Authentication" Dialog?

https://ttssh2.osdn.jp/manual/4/en/usage/ssh.html#ssh_auth_dialog

2020-11-26 01:36 Updated by: None
Comment

Reply To nmaya

Hi, Is it from "SSH Authentication" Dialog? https://ttssh2.osdn.jp/manual/4/en/usage/ssh.html#ssh_auth_dialog

Yes Absolutely. On this picture the problem occurs if the "Passphrase" field has a ' | ' character.

2020-11-26 13:18 Updated by: nmaya
Comment

In my environment, authentication succeed with password "mypassw|ord"

  • Client: Windows 8.1 64bit / Tera Term 4.105
  • Server: OpenSSH 6.6
  • SSH Protocol: SSH2
  • Authentication method: password, keyboard-interactive

Is your password in remote really has '|' character? or is your keyboard really inputs '|' character?

Is authentication succeed with other ssh client software?

Attachment File List

No attachments

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login