Ticket #47962

: and / character in username cause ttermpro.exe to crash

Open Date: 2023-04-28 10:34 Last Update: 2023-05-24 09:24

5 - Medium
Score: 0
No votes
0.0% (0/0)
0.0% (0/0)


under linux, we can ssh login with command ssh -p 1234 a1:qwert-1234zxc-ggth-0011/11@example.com

if I configure Tera Term Menu with user name that contains : and / just like the above to login into ssh server. click on that Tera Term Menu item to launch ttermpro.exe for login results in a crash saying Access Violation with Tera Term 4.106

Ticket History (3/11 Histories)

2023-04-28 10:34 Updated by: None
  • New Ticket ": and / character in username cause ttermpro.exe to crash" created
2023-05-06 23:20 Updated by: zmatsuo

I could not reproduce it in my environment.

Can you reproduce it with the following command line?

ttermpro.exe example.com:22 /ssh /user=a1 /passwd=qwert-1234zxc-ggth-0011/11
2023-05-16 07:46 Updated by: None

look like it's a bug with launching new ttermpro.exe session from ttmenu to some ssh hosts with their non-conventional usernames. using command line like you had suggested with the actual hostname, username and password worked with no error or crashing

2023-05-16 08:46 Updated by: nmaya

I set parameters to ttpmenu like avobe image, and run. I couldn't confirm this issue.

host: example.com
username: a1
password: qwert-1234zxc-ggth-0011/11

Tera Term is launched with no error.

Appears "Connection timed out. Because "example.com" is not able to resolve. It’s not relevant to this issue.

user name that contains : and / just

host: example.com
username: a1:qwert-1234zxc-ggth-0011/11
password: (zero width string)

This is incorrect input. password is input to in username field. But Tera Term didn't crash.

2023-05-17 07:09 Updated by: None

host is on internal server and crash happens during authentication. if I change hostname to some non-existent host then it would just timeout like you see without crash is there anything I can try to capture to provide some useful info for debug?

2023-05-18 08:43 Updated by: nmaya

Process Explorer able to show command line string that is passed by other process when it was launched.

 +- ttermpro.exe <- Please see its "command line" (while "Access Violation" message is showing, process does not die yet)

Compare above command line string to the command line string when you confirmed "worked with no error or crashing."

ttermpro.exe example.com:22 /ssh /user=a1 /passwd=qwert-1234zxc-ggth-0011/11

And please let us know the difference.


(Edited, 2023-05-18 12:01 Updated by: nmaya)
2023-05-20 08:34 Updated by: None

from ProcessHacker/SystemInformer, ttmenu launched ttermpro.exe commandline has an additional /auth=password option immediately after /ssh. if I add /auth=password to the commandline, then I get the same crash

2023-05-20 12:43 Updated by: nmaya

I called this from command prompt.

ttermpro.exe  192.168.x.x:22 /ssh /user=a1 /passwd=qwert-1234zxc-ggth-0011/11 /auth=password

Login failed with a message "SSH2 auto-login error: user authentication failed." Because my host 192.168.x.x doesn't have user "a1" whose password is "qwert-1234zxc-ggth-0011/11"

Launch and authentication without crash in my PC. I checked a variable that stores password. In Visual Studio, passed "qwert-1234zxc-ggth-0011/11" (included "/") is stored correctly.

Please set LogLevel=100 to TERATERM.INI in "TTSSH" section, and launch Tera Term. Please show us TTSSH.log. It can tell when Tera Term dies. (if nothing is logged, before communication. if some communication is logged, Tera Term died after last event.)

2023-05-24 09:18 Updated by: None

do you know where can I find the TTSSH.LOG file?

2023-05-24 09:24 Updated by: None

1. for TTSSH.LOG, it looks like I need to launch ttermpro.exe with elevated permission to generate the log in the same directory as ttermpro.exe. TT is installed at default path of Program Files (x86)\teraterm 2. launch ttermpro.exe with elevated permission and that /auth=password option doesn't crash, so this crash seems to be related to permission or access issue

Attachment File List


You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login