From 18 Jan, 2021 0:00 UTC: All services will be temporary unavailable for maintenance

Forums: 利用方法 (Thread #5078)

0.8.0がEclipseからインストールできません (2004-05-03 01:29 by Anonymous #9336)

Eclipse3.0のダウンロード解説(http://webpub.narucy.com/download.html)に従ってWeb Publisher 0.8.0 のインストールを試みたのですが、Web Publisherのラジオボタンにチェックを付けて先に進もうとすると以下のようなエラーが出てしまいました。

Unable to access "http://webpub.narucy.com/".
Error parsing site stream. [The XML stream is not a valid default "site.xml" file. The root tag is not site.]
Unable to access Site stream: "http://webpub.narucy.com/site.xml" [http://webpub.narucy.com/site.xml]

環境は以下の通りです。
OS: WindowsXP(Home Edition)
Eclipse: 3.0M8
Java: J2RE1.4.2_03

Reply to #9336×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

RE: 0.8.0がEclipseからインストールできません (2004-05-03 11:20 by Anonymous #9344)

ごめんなさい
site.xml 消してしまいました

これでインストールできるのではないかなと
Reply to #9336

Reply to #9344×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

RE: 0.8.0がEclipseからインストールできません (2004-05-03 11:53 by Anonymous #9345)

ありがとうございます。きちんとインストールできました。
バージョンアップが待ち遠しかったので、存分に楽しませていただくことにします。
Reply to #9344

Reply to #9345×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

RE: 0.8.0がEclipseからインストールできません (2004-05-17 00:15 by Anonymous #9529)

インストールの話なので、スレッドを続けます。

0.8を Feature updateからインストールしたのですけれど、
・書き出ししません (public_htmlが空のまま)
・Run > Run で Link check の選択肢がありません

環境は以下の通りです。
・Windows XP Pro
・JDK 1.4.2
・Eclipse 3.0M8
・Ruby 1.8.1 (2003-12-25 cygwin)
・amrita (タイムスタンプは2004-01-25、バージョンはどこでわかるのかな?cygwinと一緒に入っていたものです)
・RDT 0.4.1
・Ruby, erb, armitaのパスは見つかっています。

何か問題があれば教えてください。
Reply to #9345

Reply to #9529×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

RE: 0.8.0がEclipseからインストールできません (2004-05-18 11:05 by Anonymous #9538)

私も同様の症状で、一切書き出しが行われません。

関係あるかわかりませんが、
.publish の<mapping>タグからpattern属性が消えてしまいます。
ht_sourcesのpropertyを開いて、
Publish Doscriptor Definitionを見ると、
File Match Patternの所が全て空欄になっていました。
ここでAddを選び、新たなmappingを作成すると、
最初だけFile Match Patternが表示されますが、
OKを押して一度Property画面を閉じた後に、
再度見てみるとやはりFile Match Petternは消えています。

手書きで.publishを修正して、
<mapping pattern="**/*">などと書いてやれば、
property画面でもそれが正しく反映されます。
ところが、OKを押した時点で、
このタグが<mapping>と書き変わってしまうようです。
Reply to #9529

Reply to #9538×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

RE: 0.8.0がEclipseからインストールできません (2004-05-19 23:26 by Anonymous #9574)

プロパティダイアログから .publishファイルを設定する、ところにバグがありまました。次のバージョン(0.8.1)では修正しています。
Reply to #9538

Reply to #9574×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

RE: 0.8.0がEclipseからインストールできません (2004-05-20 22:48 by narucy #9589)

Eclipseをインストールしているディレクトリ(と、その上位のディレクトリ)にスペースが含まれていると、Web Publisher はそれを正常に扱えないかもしれません。(私もまだ検証していません。)
Reply to #9529

Reply to #9589×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

RE: 0.8.0がEclipseからインストールできません (2004-05-21 11:24 by Anonymous #9590)

mapping属性の症状、私もそうなりました。
# スペースを含むディレクトリ名は使っていません。

現在、Feature updateからは 0.8.1は見つからないのですが、
CVSは修正されてますか?
(職場がファイアウォール内にいるので、残念ながらすぐには見に行けないです)

Reply to #9589

Reply to #9590×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

RE: 0.8.1が動かない (2005-04-01 00:49 by Anonymous #13533)

0.8.1ですが、私の所でも書き出しが全く働きません。
Eclipse 3.0.0/3.0.2の両方を試してみましたがダメでした。
Eclipse2.1上で0.5.7が動いているのでRuby関連は大丈夫なはずです。
わざとエラーになるようなものをソースに書いてもエラーさえ表示されません。
どうすればよいのでしょうか?

ちなみに、なんだか動きが全然無いのでもう開発中止になっているのでしょうか?
Reply to #9589

Reply to #13533×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

RE: 0.8.1が動かない (2005-04-17 18:34 by Anonymous #13753)

たまに書き込んでいる者です。

以下の環境で、動いています。
・eclipse-win32 ver. 3.0.1 (200409161125)
・web publisher 0.8,1
・ruby 1.8.2 [2004-12-25 i386-mswin32] artonさんのActiveScriptRuby
・amrita 1.0.2 堀川さんパッチすみ

たしか、インストール直後に動きませんでしたが、rd2html-extを入れたら直ったように思います。

それから、Auto Publishに失敗することがあるのですが、
その場合は public_htmlフォルダを消去してから、
Project > Republish を起動させると、しばらく調子がいいです。

以上、ご参考になれば幸いです。

> ちなみに、なんだか動きが全然無いのでもう開発中止になっているのでしょうか?

。。。
私も、あるサイトをwebpubで構築してみており、まあ満足しています。
ただ、おかしな動作もあるので、自信を持って人に薦められないのが残念です。
Reply to #13533

Reply to #13753×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

RE: 0.8.1が動かない (2005-04-21 23:12 by Anonymous #13836)

情報ありがとうございました。
rubyをmswin32バイナリにして、rd2html-extを導入したところ書き出しが出来るようになりました。
ただ、Cygwin版ではまだうまく行っていません。
もともとMacOSXでも動くようにしたくて3.0にしたかったのですが、ちょっと揺らいできました(汗)

3.0系はスクリプトが結構変わっているんですねぇ。
2.0用のプロジェクトをそのまま移そうとしたら怒られて凹みましたが……。
なんだか、これからの拡張が視野に入ったような作りになっている様な気がするので、是非とも開発を継続していただきたいと思っています。
私自身のサイトの構築に0.57を使っているので、開発中止は結構痛い(汗)
Reply to #13753

Reply to #13836×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

RE: 0.8.1が動かない (2005-04-29 21:04 by Anonymous #13926)

> rubyをmswin32バイナリにして、rd2html-extを導入したところ書き出しが出来るようになりました。

書き込んだときには、ハズしたかもしれないと後悔しましたが、お役に立てて何よりです。

> ただ、Cygwin版ではまだうまく行っていません。
試してみましたが、同じくです。
public_htmlを削除してからpublishしても作成してくれません。
やはりファイル・フォルダ関係の不具合だと思います。

> もともとMacOSXでも動くようにしたくて3.0にしたかったのですが、ちょっと揺らいできました(汗)

cygwinより macOSXの方が素性はよいと思います。
(webpubのソースは、追いかけていないですけど。)

> 3.0系はスクリプトが結構変わっているんですねぇ。
> 2.0用のプロジェクトをそのまま移そうとしたら怒られて凹みましたが……。

こちらは難しいことをしないので、0.57系と0.8系の違いを余り感じていませんでした。
でも、amrita で問題が発生するので、テンプレートをerbに変更しようかとも考えています。

> なんだか、これからの拡張が視野に入ったような作りになっている様な気がするので、是非とも開発を継続していただきたいと思っています。
> 私自身のサイトの構築に0.57を使っているので、開発中止は結構痛い(汗)

作者さんに反応頂くのがいいですよねえ。
Reply to #13836

Reply to #13926×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

RE: 0.8.0がEclipseからインストールできません (2004-05-23 16:21 by narucy #9603)

Link check は 0.8.0 では実装してないです。(説明し忘れていました)

.metadata\.log ファイルか、.metadata\.plugins\com.narucy.webpub.core\publishLogs\*\*.stderr ファイルに何かあれば報告してくれると何かわかるかもしれません。
Reply to #9529

Reply to #9603×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

インタプリタ設定は再起動が必要というバグがありました (2004-06-10 13:50 by narucy #9834)

いまさらながら、Preference のメニューからインタプリタの位置を設定しても、再起動しなければ、書き出し時にはその設定は反映されないというバグがありました。

次のバージョンでは直そうと思いますが(0.8.2)、それまではインタプリタを設定するたびに、再起動していただきたいと思います。
Reply to #9529

Reply to #9834×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

ソースから 0.8 インストール (2004-06-06 19:01 by Anonymous #9810)

今度はソースからビルドしてみようと
webpub_sources.zipをとってきてみました。
が、build.xml が入っていません。

0.5.7のソースのbuild.xmlをコピーしてみましたけど、
浅はかな期待でした。
narucyさんの修正を是非お願います。

ちなみに、ソースを更新した日付もWEBページに書いておいて欲しいです。
実際、WEBページの作成ツールを紹介しているのだから、
もっと頻繁に更新しないと見捨てられますよ。
Reply to #9336

Reply to #9810×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login

site.xml と feature.xml を使います (2004-06-10 15:26 by narucy #9835)

PDEを用いたプラグイン開発では、build.xml は feature.xml から生成できます。
Reply to #9810

Reply to #9835×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Login