Ticket #27061

Open Date: 2012-01-06 09:06

Last Update: 2012-01-20 08:15

Doesn't work with Visual Studio

Priority:5 - MediumMileStone:(None)
Type:BugsSeverity:5 - Medium
Component:(None)Status:Open [Owner assigned]


I installed xkeymacs on my Windows 7 box, and it works great with all other apps, but doesn't work with Visual Studio 2010. I've tried applying with the xkeymacs dropdown "Microsoft Visual Studio .NET", I've tried changing it then restarting Visual Studio, also rebooting the machine. With nothing will it actually recognize the changed keystrokes.

The funny thing is that I have another Windows 7 machine where it works fine with Visual Studio. I also have tried to completely reinstall Visual Studio with no good result.

Any ideas?

Attachment File

Attachment File ListNo attachments
Add New attachment
Add attachment filesPlease login to add new attachment

Ticket History - 2/2 Histories

2012-01-06 09:06 Updated by: None

  • New Ticket "Doesn't work with Visual Studio" created

2012-01-20 08:15 Updated by: fujieda

  • Owner Update from (None) to fujieda
  • Resolution Update from None to Accepted
  • Priority Update from 9 - Highest to 5 - Medium


I guess you start Visual Studio in the administrative mode on the box. XKeymacs can't work any application running in this mode. If you don't so, I can't find another reason where it can't work only for Visual Studio.

I will fix a bug where it shows the wrong name in the dropdown list for Visual Studio anyway.

Add Comment/Update #27061 (Doesn't work with Visual Studio)

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login