Ticket #42961

wrong help text for the trade_revenue_style server option

Open Date: 2021-10-01 07:19 Last Update: 2021-10-09 01:36

Reporter:
Owner:
Type:
Status:
Closed
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Fixed
File:
1

Details

Attempting my first patch for Freeciv, a simple one to get used to the workflow. Please tell me if something is not in line with recommended practice and I'll do it better next time.

Ticket History (3/7 Histories)

2021-10-01 07:19 Updated by: log65536
  • New Ticket "wrong help text for the trade_revenue_style server option" created
2021-10-01 07:19 Updated by: log65536
  • File 0001-Fix-help-text-for-the-trade_revenue_style-server-opt.patch (File ID: 7571) is attached
2021-10-01 07:20 Updated by: log65536
  • File 0001-Fix-help-text-for-the-trade_revenue_style-server-opt.patch (File ID: 7571) is deleted
2021-10-01 07:23 Updated by: log65536
  • Component Update from (None) to Documentation
2021-10-01 08:39 Updated by: cazfi
  • Owner Update from (None) to cazfi
  • Resolution Update from None to Accepted
  • Milestone Update from (None) to 3.0.0 (closed)
Comment

Patch seems perfect to me.

Workflow note about what happens next: As osdn does not have a ticket state "In Testing" / "In Review", or anything like that, we use "Accepted" (which we have no other use for) to mark patch that has entered public review period, minimum of 36h. In this case we have the 3.0.0-beta3 release coming in a week, and as this 1) is not a regression since beta2 2) introduces translatable string change, we're unlikely to push it in last minute but rather wait until beta3 is out.

2021-10-09 01:36 Updated by: cazfi
  • Status Update from Open to Closed
  • Resolution Update from Accepted to Fixed

Attachment File List

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login