Ticket #44593

Wrong nation in "..have lost <tech>" message

Open Date: 2022-05-14 21:59 Last Update: 2022-05-15 04:15

Reporter:
Owner:
Type:
Status:
Open [Owner assigned]
Component:
MileStone:
Priority:
5 - Medium
Severity:
5 - Medium
Resolution:
Accepted
File:
1

Details

"You made a mistake in transferring Combined Arms and lost it."
"The Scythians have lost Combined Arms."

This doesn't seem right. The Scythians are the ones who were supposed to receive the tech - they never had it. Not sure if the latter message is supposed to tell the same thing as the first; that I've lost the tech, or that the Scythians failed to receive the tech.

Ticket History (3/4 Histories)

2022-05-14 21:59 Updated by: cazfi
  • New Ticket "Wrong nation in "..have lost <tech>" message" created
2022-05-15 03:35 Updated by: cazfi
Comment

The situation here was that both parties were unlucky with their dice roll on the tech transfer. Latter message indeed refers to the receivers failure to get the tech. There's a lot more wrong there than the form of the message. They never had the tech (even if the transfer were to success, that would happen only later), but the situation is handled like they are losing something they had. One obvious problem is subtracting techs_researched counter.

2022-05-15 04:15 Updated by: cazfi
  • Owner Update from (None) to cazfi
  • Resolution Update from None to Accepted
  • Milestone Update from (None) to 3.0.2
  • Component Update from (None) to Server

Edit

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login