Ticket #37048

SendMulticast Command Won't Transmit an Integer value of 0x00 or 0x01, but the Send Command Will

Open Date: 2017-03-06 14:29 Last Update: 2017-08-31 22:33

Score: 0
No votes
0.0% (0/0)
0.0% (0/0)


I have observed an interesting behavior that I was not expecting. If I send out the integers from 0x00 to 0xFF using the Send command, they go out just fine, but if I try to send them out with the SendMulticast command 0x00 and 0x01 don't work. The 0x00 just doesn't seem to get sent and the 0x00 gets sent as 0xFF! I already switched the language to English from UTF-8 so that the upper values from 0x80 to 0xFF would send properly as a single byte.

My test setup is as follows: 1. Terminal 1 (named Terminal1) is connected to COM1 2. Terminal 2 (named Terminal2) is connected to COM2 3. I am running a RealTerm Terminal on COM3 (set to display received data as hex) 4. COM2 and COM3 are physically connected with a null-modem cable

If I run the following macro on Terminal 2, I get the numbers from 0x00 to 0xFF on the RealTerm Terminal on COM3 as expected: for i 0x00 0xFF send i next

If I run the equivalent macro on Terminal 1, I get 0xFF and the numbers from 0x02 to 0xFF on the RealTerm Terminal on COM3, NOT as expected: for i 0x00 0xFF SendMulticast "Terminal1" i next

Why can I send an integer value of 0x00 or 0x01 with the Send command, but not with the SendMulticast command? I would greatly appreciate any help in sorting this out. This is causing no small problem in my macro since all of the bytes with a value of 0x00 are getting skipped and the ones with a value of 0x01 are getting converted to 0xFF.

Ticket History (3/4 Histories)

2017-03-06 14:29 Updated by: jcorra
  • New Ticket "SendMulticast Command Won't Transmit an Integer value of 0x00 or 0x01, but the Send Command Will" created
2017-07-20 21:13 Updated by: doda
  • Milestone Update from (None) to Tera Term 4.96 (closed)
  • Owner Update from (None) to doda
  • Resolution Update from None to Accepted
  • Details Updated
2017-07-24 12:53 Updated by: doda
  • Resolution Update from Accepted to Fixed

This issue will be fixed in next release.

2017-08-31 22:33 Updated by: doda
  • Ticket Close date is changed to 2017-08-31 22:33
  • Status Update from Open to Closed

Attachment File List

No attachments


You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Login