Download List

Sponsored link

Project Description

XOOPSの統合パッケージを開発するプロジェクトです。

System Requirements

System requirement is not defined

Released at 2010-08-24 15:06
NetCommons mysql554_1 (1 files Hide)

Release Notes


問題点
MySQL 5.5.4 ではインストールやアップデートが出来ない。

原因
文法が変わり、TYPE=MyISAM が使えなくなったため。

対策
TYPE=MyISAM を ENGINE=MyISAM に置き換えた。

2次的な影響
アップデート時に、テーブルが生成できないと、アクセス不能になる。
2.3.0.0 では config_language テーブルがある前提になっているが、
これがないため。
config_language テーブルなしでも動作するように対策した。

■ ファイル
下記を同封しています。

TYPE=MyISAM を ENGINE=MyISAM に置き換えた。
(1) webapp/components/database/Sqlutility.class.php
(2) webapp/modules/language/update/Update.class.php
(3) webapp/modules/mobile/update/Update.class.php
(4) webapp/modules/module/update/Update.class.php
(5) webapp/modules/system/update/Update.class.php

config_language テーブル なしの対策
(6) webapp/components/config/View.class.php

■ 参考
MySQL め、相変わらず中途半端だな
http://www.bugbearr.jp/?%E6%97%A5%E8%A8%98%2F2010-05-01

[mysql]MySQL 5.5.3-m3 で廃止になった変数やオプションなどを整理しました
http://d.hatena.ne.jp/sakaik/20100414/mysql533obsol

Changelog

No Changelogs